summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 09:12:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 09:21:59 +0100
commitcaf94ad181303148d7b2013f4eab13e8494698ee (patch)
tree23d8fba6871ffc386f9a481f8a3ccdd64ac9a613 /dev-python/uvloop/uvloop-0.15.2.ebuild
parentdev-embedded/u-boot-tools: bump up to 2020.04-r2 (diff)
downloadgentoo-caf94ad181303148d7b2013f4eab13e8494698ee.tar.gz
gentoo-caf94ad181303148d7b2013f4eab13e8494698ee.tar.bz2
gentoo-caf94ad181303148d7b2013f4eab13e8494698ee.zip
dev-python/uvloop: Bump to 0.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uvloop/uvloop-0.15.2.ebuild')
-rw-r--r--dev-python/uvloop/uvloop-0.15.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/uvloop/uvloop-0.15.2.ebuild b/dev-python/uvloop/uvloop-0.15.2.ebuild
new file mode 100644
index 000000000000..1ce46b172f5b
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.15.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="https://github.com/magicstack/uvloop"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/libuv-1.11.0:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ cat <<EOF >> setup.cfg || die
+[build_ext]
+use-system-libuv=1
+EOF
+
+ # flake8 only
+ rm tests/test_sourcecode.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_ext --inplace build_sphinx
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/sphinx/html/." )
+ distutils-r1_python_install_all
+}