summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-02 21:03:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-02 21:05:09 +0200
commit5d1adc7f70a80463a1af2a858197de94ebb10460 (patch)
tree0f25e5748f6751ac00bcbd75042b5d17cb6fadf7 /dev-python/vcrpy
parentdev-python/typing-extensions: Remove old (diff)
downloadgentoo-5d1adc7f70a80463a1af2a858197de94ebb10460.tar.gz
gentoo-5d1adc7f70a80463a1af2a858197de94ebb10460.tar.bz2
gentoo-5d1adc7f70a80463a1af2a858197de94ebb10460.zip
dev-python/vcrpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index ce78bd7d0563..33a6913fe413 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,2 +1 @@
-DIST vcrpy-4.1.1.tar.gz 329508 BLAKE2B b6981150a8fd742301e0d7897d84855c741c97307bbb5c5751680f3d33d69d6333a18d714fcc14cb018f5dd6c02e840e1313136660c4459e2755d448fc0b07e9 SHA512 afa1904bff37bfd2d278ed49fa3982a357eb6bb113818b532044da0f11a9dd877cc152d7f0d81d88bdc0f870521b1241f6aecf959f668211904e3c6c7cea4ad8
DIST vcrpy-4.2.0.gh.tar.gz 331096 BLAKE2B dccb9310da42c6f75d0d503cb64aa09876447098bff2ad6a1507a0e0907ce05a89d46ccc159e79f310e027fc8f3075b7474274ad39ca4778acbc6d2a8f633004 SHA512 61eeec585fc78be1ae6d4f9047123c9680611e436bb5980fb7c6b885e16b2ef9bd5ce921efff7e87a222b3662c7009dbf0a8df24cdb9849d09deb24957ba4889
diff --git a/dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild b/dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild
deleted file mode 100644
index e1d011d9d398..000000000000
--- a/dev-python/vcrpy/vcrpy-4.1.1-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="
- https://github.com/kevin1024/vcrpy/
- https://pypi.org/project/vcrpy/
-"
-SRC_URI="
- https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these tests require Internet
- tests/integration/test_aiohttp.py
- tests/integration/test_boto.py
- tests/integration/test_httpx.py
- tests/integration/test_wild.py::test_flickr_should_respond_with_200
- tests/integration/test_wild.py::test_amazon_doctype
- tests/unit/test_stubs.py::TestVCRConnection::testing_connect
-
- # probably unhappy about ssl module being more strict now
- 'tests/integration/test_httplib2.py::test_effective_url[https]'
- 'tests/integration/test_requests.py::test_effective_url[https]'
- 'tests/integration/test_requests.py::test_redirects[https]'
- 'tests/integration/test_urllib2.py::test_effective_url[https]'
- 'tests/integration/test_urllib3.py::test_redirects[https]'
- )
-
- local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- epytest
-}