summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-05 11:36:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-05 11:36:02 +0200
commit4ff4eeca25482d8827c179579262bd5e51551e5b (patch)
treec89114659838e673bd422cfa687130c73fb5f025 /dev-python/vcstools/vcstools-0.1.39.ebuild
parentdev-ros/genlisp: bump to 0.4.16 (diff)
downloadgentoo-4ff4eeca25482d8827c179579262bd5e51551e5b.tar.gz
gentoo-4ff4eeca25482d8827c179579262bd5e51551e5b.tar.bz2
gentoo-4ff4eeca25482d8827c179579262bd5e51551e5b.zip
dev-python/vcstools: bump to 0.1.39
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/vcstools/vcstools-0.1.39.ebuild')
-rw-r--r--dev-python/vcstools/vcstools-0.1.39.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/vcstools/vcstools-0.1.39.ebuild b/dev-python/vcstools/vcstools-0.1.39.ebuild
new file mode 100644
index 000000000000..22eb44c3cd5c
--- /dev/null
+++ b/dev-python/vcstools/vcstools-0.1.39.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/vcstools"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Python library for interacting with various VCS systems"
+HOMEPAGE="http://wiki.ros.org/vcstools"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/vcstools/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ #git config --global user.email "you@example.com"
+ #git config --global user.name "Your Name"
+
+ nosetests --with-coverage --cover-package vcstools || die
+}