summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-07-08 21:03:30 +0200
committerAmy Liffey <amynka@gentoo.org>2017-07-08 21:03:30 +0200
commit1bfa1307204e189091b66b385181d94a50da5c07 (patch)
tree709e68a8231205bce19c2b03e8e0d31235a9a88d /dev-python/vdirsyncer
parentgames-util/xgamer: Add build fix for Perl 5.26, bug 623594 (diff)
downloadgentoo-1bfa1307204e189091b66b385181d94a50da5c07.tar.gz
gentoo-1bfa1307204e189091b66b385181d94a50da5c07.tar.bz2
gentoo-1bfa1307204e189091b66b385181d94a50da5c07.zip
dev-python/vdirsyncer: version bump 0.16.0 bug #623748
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-python/vdirsyncer')
-rw-r--r--dev-python/vdirsyncer/Manifest1
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.16.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
index dd47fdfa1f50..bc2da771f5e3 100644
--- a/dev-python/vdirsyncer/Manifest
+++ b/dev-python/vdirsyncer/Manifest
@@ -1 +1,2 @@
DIST vdirsyncer-0.14.0.tar.gz 105839 SHA256 28211a857c03ea6cdad22ca74505758a743dbb8bc224e5bcd558a73efd1370d5 SHA512 e8a9f74032bc625db60206a210d7c00fad224b7eccfd1caeabbb97b443fd90ae8a00e2fdfabfd6118864dd9b6d8922eb9906091a8e341334848f66e55ed5fcdd WHIRLPOOL c1823b0db07e1b2deaed5cf2b69a86bb025d47d9ba79d408fdddfa81706f9046b43f8076f4ea418037639a5a52b9fff33e75bae1cfbf9c01f4920139a5e36d99
+DIST vdirsyncer-0.16.0.tar.gz 113408 SHA256 cfdbfa799373ca08f533bfc57bd0d3afefe8a2c5f845782db38b889a19aca958 SHA512 d15a78d49da8ec033be85a3b127d5a788d34ba160207068f9cbd038efd950df809222da9b26ded46f53898b59c8e22049ca003c593e5ce4153ba744e9cf94dd4 WHIRLPOOL e8677ecf3860748b47701b6a8cf4673e6b9eed6450158489028398ba2877b601577307d8bd81548af75a2335841be3470f418226f76df2a61534e601854c823b
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.0.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.0.ebuild
new file mode 100644
index 000000000000..b224f165d05e
--- /dev/null
+++ b/dev-python/vdirsyncer/vdirsyncer-0.16.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="https://github.com/pimutils/vdirsyncer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/click-threading-0.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+ !=dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.1[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+python_test() {
+ # skip tests needing servers running
+ local -x DAV_SERVER=skip
+ local -x REMOTESTORAGE_SERVER=skip
+ # pytest dies hard if the envvars do not have any value...
+ local -x CI=false
+ local -x DETERMINISTIC_TESTS=false
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}