summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-01 15:55:02 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-01 16:56:22 +0200
commitc33d0bac0ab0c919486a405f8909f54725f033dd (patch)
tree4b6d1a77a88f350092c74f977c70fb34616e5ca1 /dev-python/vdirsyncer
parentdev-python/vdirsyncer: Add missing setuptools dep (diff)
downloadgentoo-c33d0bac0ab0c919486a405f8909f54725f033dd.tar.gz
gentoo-c33d0bac0ab0c919486a405f8909f54725f033dd.tar.bz2
gentoo-c33d0bac0ab0c919486a405f8909f54725f033dd.zip
dev-python/vdirsyncer: Write partial test support
Diffstat (limited to 'dev-python/vdirsyncer')
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.14.0.ebuild22
1 files changed, 19 insertions, 3 deletions
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.14.0.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.14.0.ebuild
index 6d6752794a42..7f76580c3c67 100644
--- a/dev-python/vdirsyncer/vdirsyncer-0.14.0.ebuild
+++ b/dev-python/vdirsyncer/vdirsyncer-0.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE=""
+IUSE="test"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
>=dev-python/click-log-0.1.3[${PYTHON_USEDEP}]
@@ -25,6 +25,22 @@ RDEPEND="dev-python/click[${PYTHON_USEDEP}]
>=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.1[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
+ )"
DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+python_test() {
+ # skip tests needing servers running
+ local -x DAV_SERVER=skip
+ local -x REMOTESTORAGE_SERVER=skip
+ # pytest dies hard if the envvars do not have any value...
+ local -x CI=false
+ local -x DETERMINISTIC_TESTS=false
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}