summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-01-13 19:05:28 +0100
committerSebastian Pipping <sping@gentoo.org>2020-01-13 19:06:38 +0100
commitd690fce639b49c3e5e10ed0472ff507688976f49 (patch)
tree782fc416120a7c2f599cfd6f316417241a52c3ae /dev-python/virtualenv-clone
parentnet-dns/avahi: call systemd_reenable in postinst (diff)
downloadgentoo-d690fce639b49c3e5e10ed0472ff507688976f49.tar.gz
gentoo-d690fce639b49c3e5e10ed0472ff507688976f49.tar.bz2
gentoo-d690fce639b49c3e5e10ed0472ff507688976f49.zip
virtualenv-clone: 0.5.3 + EAPI 7 + py38
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'dev-python/virtualenv-clone')
-rw-r--r--dev-python/virtualenv-clone/Manifest1
-rw-r--r--dev-python/virtualenv-clone/virtualenv-clone-0.5.3.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/virtualenv-clone/Manifest b/dev-python/virtualenv-clone/Manifest
index efd9e98135da..58feb6478b16 100644
--- a/dev-python/virtualenv-clone/Manifest
+++ b/dev-python/virtualenv-clone/Manifest
@@ -1 +1,2 @@
DIST virtualenv-clone-0.2.6.tar.gz 5691 BLAKE2B e049f7661939d0cc9b5b85d4bb49c34d62c1f7dc388b974b55e0ef5899c4f44006ad1d2b0df2c50aee3047b54d8645666684df8ddac4f1f006c7e7fdc98e6f40 SHA512 e4963532a8f954ab9840f9f950ccb9c5a8c2bb863c6b0bc72576e5f464b321ef098f199192dbdbb342a232223be9d47b170ea6222d3ecb5848f965cb5ddf8256
+DIST virtualenv-clone-0.5.3.tar.gz 6226 BLAKE2B 8d86b9c44fc2db49d609045342352c2d06a6b3008c44a891b9d1e1a7225d77c69708999ab1b1097df1f76bd858ca5cefec8693e4a9ccf74589bd159de37c442f SHA512 1ba34830d21e8d4ea2f448defbf769afb3a63049c31fab46cfd184f4e5a8745d58984392add327fd5139e5e05a61c172266e2102439577c0b3702152f87fef0d
diff --git a/dev-python/virtualenv-clone/virtualenv-clone-0.5.3.ebuild b/dev-python/virtualenv-clone/virtualenv-clone-0.5.3.ebuild
new file mode 100644
index 000000000000..58aa0a783d08
--- /dev/null
+++ b/dev-python/virtualenv-clone/virtualenv-clone-0.5.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+# rdepend is correct despite warning, see https://bugs.gentoo.org/705362
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A script for cloning a non-relocatable virtualenv"
+HOMEPAGE="https://github.com/edwardgeorge/virtualenv-clone"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""