summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-26 18:25:44 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-26 18:45:30 +0100
commit5968c5c28a6b6f608c47699bae34d85d166b8e02 (patch)
tree76499ea18750e0b2733208946fdc77f8c574e084 /dev-python/virtualenv
parentdev-python/simplejson: Remove old (diff)
downloadgentoo-5968c5c28a6b6f608c47699bae34d85d166b8e02.tar.gz
gentoo-5968c5c28a6b6f608c47699bae34d85d166b8e02.tar.bz2
gentoo-5968c5c28a6b6f608c47699bae34d85d166b8e02.zip
dev-python/virtualenv: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/virtualenv-15.1.0.ebuild50
-rw-r--r--dev-python/virtualenv/virtualenv-16.7.7.ebuild57
-rw-r--r--dev-python/virtualenv/virtualenv-16.7.8.ebuild60
3 files changed, 0 insertions, 167 deletions
diff --git a/dev-python/virtualenv/virtualenv-15.1.0.ebuild b/dev-python/virtualenv/virtualenv-15.1.0.ebuild
deleted file mode 100644
index 18c9ac8c8cc2..000000000000
--- a/dev-python/virtualenv/virtualenv-15.1.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-DOCS=( docs/index.rst docs/changes.rst )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-12.1.1-skip-broken-test.patch
-)
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/virtualenv/virtualenv-16.7.7.ebuild b/dev-python/virtualenv/virtualenv-16.7.7.ebuild
deleted file mode 100644
index 31e1e3c37996..000000000000
--- a/dev-python/virtualenv/virtualenv-16.7.7.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# pypy{,3} dropped until test deps are tested/updated
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND=">=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pypiserver[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )"
-
-DOCS=( docs/index.rst docs/changes.rst )
-
-PATCHES=(
- "${FILESDIR}/virtualenv-16.7.7-tests.patch"
-
- # disable tests that need internet access
- "${FILESDIR}/virtualenv-16.7.7-tests-internet.patch"
-)
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
-
-python_test() {
- cp "${S}"/LICENSE.txt "${BUILD_DIR}"/lib || \
- die "Could not copy LICENSE.txt with ${EPYTHON}"
-
- pytest -vv tests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/virtualenv/virtualenv-16.7.8.ebuild b/dev-python/virtualenv/virtualenv-16.7.8.ebuild
deleted file mode 100644
index 102845894fc4..000000000000
--- a/dev-python/virtualenv/virtualenv-16.7.8.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# pypy{,3} dropped until test deps are tested/updated
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND=">=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pypiserver[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )"
-
-DOCS=( docs/index.rst docs/changes.rst )
-
-PATCHES=(
- "${FILESDIR}/virtualenv-16.7.7-tests.patch"
-
- # disable tests that need internet access
- "${FILESDIR}/virtualenv-16.7.7-tests-internet.patch"
-
- # test fixes for pypy
- "${FILESDIR}/virtualenv-16.7.8-tests-pypy.patch"
-)
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
-
-python_test() {
- cp "${S}"/LICENSE.txt "${BUILD_DIR}"/lib || \
- die "Could not copy LICENSE.txt with ${EPYTHON}"
-
- pytest -vv tests || die "Tests fail with ${EPYTHON}"
-}