summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 01:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 08:06:35 +0200
commit5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f (patch)
treef2de3644b75e298ceeaed790daab2aa73e57d62f /dev-python/virtualenv
parentdev-python/setuptools: Partially restore ~arch keywords (diff)
downloadgentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.gz
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.bz2
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.zip
dev-python/*: Restore keywords and un-revbump for py3.5
Restore keywords that were removed unnecessarily, and collapse unnecessary revbumps on packages with added python3.5 support.
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild53
-rw-r--r--dev-python/virtualenv/virtualenv-13.1.2.ebuild12
2 files changed, 8 insertions, 57 deletions
diff --git a/dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild b/dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild
deleted file mode 100644
index 77713a1002f8..000000000000
--- a/dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- http://www.virtualenv.org/
- https://pypi.python.org/pypi/virtualenv
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/pip-7.1.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-DOCS=( docs/index.rst docs/changes.rst )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.2-no-versioned-script.patch
- "${FILESDIR}"/${PN}-12.1.1-skip-broken-test.patch
-)
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -vvx || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${S}"/docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/virtualenv/virtualenv-13.1.2.ebuild b/dev-python/virtualenv/virtualenv-13.1.2.ebuild
index c67a30fafa66..0d4b20406c5b 100644
--- a/dev-python/virtualenv/virtualenv-13.1.2.ebuild
+++ b/dev-python/virtualenv/virtualenv-13.1.2.ebuild
@@ -2,14 +2,18 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="http://www.virtualenv.org/ https://pypi.python.org/pypi/virtualenv https://github.com/pypa/virtualenv/"
+HOMEPAGE="
+ http://www.virtualenv.org/
+ https://pypi.python.org/pypi/virtualenv
+ https://github.com/pypa/virtualenv/
+"
SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
@@ -40,7 +44,7 @@ python_compile_all() {
}
python_test() {
- py.test || die "Tests fail with ${EPYTHON}"
+ py.test -vvx || die "Tests fail with ${EPYTHON}"
}
python_install_all() {