summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 16:27:48 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 16:46:38 -0800
commit622f6d7e1cb55f0dabd4f0d4227f38c1dd2385ff (patch)
treea6254d66a1aab24976003fe34fbaeeaa6f92ffe8 /dev-python/virtualenv
parentdev-python/flask: Prepare for 3.8, fix tests (diff)
downloadgentoo-622f6d7e1cb55f0dabd4f0d4227f38c1dd2385ff.tar.gz
gentoo-622f6d7e1cb55f0dabd4f0d4227f38c1dd2385ff.tar.bz2
gentoo-622f6d7e1cb55f0dabd4f0d4227f38c1dd2385ff.zip
dev-python/virtualenv-16.7.7: fix USE=doc
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/virtualenv-16.7.7.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/virtualenv/virtualenv-16.7.7.ebuild b/dev-python/virtualenv/virtualenv-16.7.7.ebuild
index e04ef4458d11..cb3757140702 100644
--- a/dev-python/virtualenv/virtualenv-16.7.7.ebuild
+++ b/dev-python/virtualenv/virtualenv-16.7.7.ebuild
@@ -62,7 +62,15 @@ python_check_deps() {
}
python_compile_all() {
- use doc && emake -C docs html
+ if use doc; then
+ sed -i -e 's:^intersphinx_mapping:disabled_&:' \
+ docs/conf.py || die
+
+ sphinx-build -b html -d docs/_build/doctrees docs \
+ docs/_build/html || die
+
+ HTML_DOCS+=( "docs/_build/html/." )
+ fi
}
python_install_all() {