summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-03 08:20:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-03 08:21:16 +0200
commitdee418093fc8386988748c254285662108b13f5b (patch)
tree7c80cd0726834ee88f033706a6de6b74564e135d /dev-python/virtualenv
parentdev-python/tqdm: Remove old (diff)
downloadgentoo-dee418093fc8386988748c254285662108b13f5b.tar.gz
gentoo-dee418093fc8386988748c254285662108b13f5b.tar.bz2
gentoo-dee418093fc8386988748c254285662108b13f5b.zip
dev-python/virtualenv: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/files/virtualenv-16.7.7-tests-internet.patch50
-rw-r--r--dev-python/virtualenv/files/virtualenv-16.7.7-tests.patch53
-rw-r--r--dev-python/virtualenv/files/virtualenv-16.7.8-tests-pypy.patch64
-rw-r--r--dev-python/virtualenv/virtualenv-16.7.10-r1.ebuild66
-rw-r--r--dev-python/virtualenv/virtualenv-20.4.4.ebuild99
6 files changed, 0 insertions, 334 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 33a5d2a2571b..25331c19f09a 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,3 +1 @@
-DIST virtualenv-16.7.10.tar.gz 5116776 BLAKE2B 42f0a4b4330850b504f8febd991ef6ecdcbb0821efdd94ca324a8cc34a68a760a8a98de97f0cb2384d8e6cbb0ce8f261995c6433886444e29b75ba0ce09ca12c SHA512 f06d7c354ce1910f04dbcbe1a77e60392653bbe4f638bafbe9284454db2c0e5d63cf9159201d0916fc01aaba91d45fb733b63096c38517fcd83fd00ed8b26d28
-DIST virtualenv-20.4.4.tar.gz 10579531 BLAKE2B 9e10c07bd191d745d6904f304787a3913c0c574bb4453549796052f27329cbc2e3700fbc6f40ff02f4e94b8f1c21458c8fbd706b05ae458c033722d3eaf04f2e SHA512 acc528cccfc80aeed2fcd7209cab7ff0f1a7d1dc01a59fdb6a07703c7905904ab68d3f4ff312e108c687d03495e82ed8d26ecc15c2b17b9e771605a46164b4bd
DIST virtualenv-20.4.7.tar.gz 10625204 BLAKE2B 1233ea45f771fb425b99c966904e2c5444e5fcb617b1d7cd34cdac097ee15566b7f4c841d444393723ed369193f33bef90ea7caa5b3c20aaf65fbde2f865abf7 SHA512 a554fb32cc46cb1cef2a2655bdae598efb52a4e71223eb10d9a36b124390546250aa11cf7da991a41ef4697523ec4562a31e35b5ab7ee8aba748ea4ff28e088b
diff --git a/dev-python/virtualenv/files/virtualenv-16.7.7-tests-internet.patch b/dev-python/virtualenv/files/virtualenv-16.7.7-tests-internet.patch
deleted file mode 100644
index 97baeb59c4eb..000000000000
--- a/dev-python/virtualenv/files/virtualenv-16.7.7-tests-internet.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff --git a/tests/test_from_source.py b/tests/test_from_source.py
-index 39d7c05..76834f7 100644
---- a/tests/test_from_source.py
-+++ b/tests/test_from_source.py
-@@ -40,6 +40,7 @@ def test_use_from_source_sdist(sdist, tmp_path, clean_python, monkeypatch, call_
- )
-
-
-+@pytest.mark.skip(reason="needs internet access")
- def test_use_from_wheel(tmp_path, extracted_wheel, clean_python, monkeypatch, call_subprocess):
- """test that we can create a virtual environment by feeding to a clean python the wheels content"""
- virtualenv_file = extracted_wheel / "virtualenv.py"
-diff --git a/tests/test_source_content.py b/tests/test_source_content.py
-index 8eae6bc..06763ee 100644
---- a/tests/test_source_content.py
-+++ b/tests/test_source_content.py
-@@ -41,6 +41,7 @@ def test_sdist_contains(sdist):
- assert not extra, " | ".join(extra)
-
-
-+@pytest.mark.skip(reason="needs internet access")
- def test_wheel_contains(extracted_wheel):
- content = set(extracted_wheel.iterdir())
-
-diff --git a/tests/test_zipapp.py b/tests/test_zipapp.py
-index d084af6..93d29e1 100644
---- a/tests/test_zipapp.py
-+++ b/tests/test_zipapp.py
-@@ -51,11 +51,13 @@ def call_wheel(tmp_path_factory, call_subprocess):
- return wheel_make_env
-
-
-+@pytest.mark.skip(reason="needs internet access")
- @pytest.mark.skipif(six.PY2, reason="seems to be broken on python2")
- def test_zipapp_basic_invocation(call_zipapp, tmp_path):
- _test_basic_invocation(call_zipapp, tmp_path)
-
-
-+@pytest.mark.skip(reason="needs internet access")
- @pytest.mark.skipif(six.PY2, reason="seems to be broken on python2")
- def test_wheel_basic_invocation(call_wheel, tmp_path):
- _test_basic_invocation(call_wheel, tmp_path)
-@@ -97,6 +99,7 @@ def test_zipapp_invocation_dash_p(call_zipapp, tmp_path):
- _test_invocation_dash_p(call_zipapp, tmp_path)
-
-
-+@pytest.mark.skip(reason="needs internet access")
- @pytest.mark.skipif(six.PY2, reason="seems to be broken on python2")
- @pytest.mark.skipif(sys.platform == "win32" and six.PY2, reason="no python 3 for windows on CI")
- def test_wheel_invocation_dash_p(call_wheel, tmp_path):
diff --git a/dev-python/virtualenv/files/virtualenv-16.7.7-tests.patch b/dev-python/virtualenv/files/virtualenv-16.7.7-tests.patch
deleted file mode 100644
index 41d3240d47d3..000000000000
--- a/dev-python/virtualenv/files/virtualenv-16.7.7-tests.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/tests/test_virtualenv.py b/tests/test_virtualenv.py
-index 620c0cb..946233b 100644
---- a/tests/test_virtualenv.py
-+++ b/tests/test_virtualenv.py
-@@ -356,6 +356,7 @@ def test_install_python_bin():
- shutil.rmtree(tmp_virtualenv)
-
-
-+@pytest.mark.skip(reason="This test does not seem to be working, and I have no idea why")
- @pytest.mark.skipif("platform.python_implementation() == 'PyPy'")
- def test_always_copy_option():
- """Should be no symlinks in directory tree"""
-diff --git a/tests/test_zipapp.py b/tests/test_zipapp.py
-index 8ef8bd1..d084af6 100644
---- a/tests/test_zipapp.py
-+++ b/tests/test_zipapp.py
-@@ -51,10 +51,12 @@ def call_wheel(tmp_path_factory, call_subprocess):
- return wheel_make_env
-
-
-+@pytest.mark.skipif(six.PY2, reason="seems to be broken on python2")
- def test_zipapp_basic_invocation(call_zipapp, tmp_path):
- _test_basic_invocation(call_zipapp, tmp_path)
-
-
-+@pytest.mark.skipif(six.PY2, reason="seems to be broken on python2")
- def test_wheel_basic_invocation(call_wheel, tmp_path):
- _test_basic_invocation(call_wheel, tmp_path)
-
-@@ -95,6 +97,7 @@ def test_zipapp_invocation_dash_p(call_zipapp, tmp_path):
- _test_invocation_dash_p(call_zipapp, tmp_path)
-
-
-+@pytest.mark.skipif(six.PY2, reason="seems to be broken on python2")
- @pytest.mark.skipif(sys.platform == "win32" and six.PY2, reason="no python 3 for windows on CI")
- def test_wheel_invocation_dash_p(call_wheel, tmp_path):
- _test_invocation_dash_p(call_wheel, tmp_path)
-diff --git a/virtualenv.py b/virtualenv.py
-index 0c47e4f..d4a1747 100755
---- a/virtualenv.py
-+++ b/virtualenv.py
-@@ -80,9 +80,9 @@ else:
- DEFAULT_CONFIG_FILE = os.path.join(DEFAULT_STORAGE_DIR, "virtualenv.ini")
-
- if IS_PYPY:
-- EXPECTED_EXE = "pypy"
-+ EXPECTED_EXE = "pypy{}".format('' if sys.hexversion < 0x3000000 else '3')
- else:
-- EXPECTED_EXE = "python"
-+ EXPECTED_EXE = "python{}.{}".format(sys.version_info.major, sys.version_info.minor)
-
- # Return a mapping of version -> Python executable
- # Only provided for Windows, where the information in the registry is used
diff --git a/dev-python/virtualenv/files/virtualenv-16.7.8-tests-pypy.patch b/dev-python/virtualenv/files/virtualenv-16.7.8-tests-pypy.patch
deleted file mode 100644
index 1e9268a5f976..000000000000
--- a/dev-python/virtualenv/files/virtualenv-16.7.8-tests-pypy.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff --git a/tests/test_virtualenv.py b/tests/test_virtualenv.py
-index 620c0cb..3284cea 100644
---- a/tests/test_virtualenv.py
-+++ b/tests/test_virtualenv.py
-@@ -5,6 +5,7 @@ import optparse
- import os
- import shutil
- import subprocess
-+import platform
- import sys
- import tempfile
- import textwrap
-@@ -342,6 +343,11 @@ def test_install_python_bin():
-
- if virtualenv.IS_WIN:
- required_executables = ["python.exe", "pythonw.exe"]
-+ elif platform.python_implementation() == 'PyPy':
-+ if sys.version_info.major < 3:
-+ required_executables = ["pypy"]
-+ else:
-+ required_executables = ["pypy3"]
- else:
- py_exe_no_version = "python"
- py_exe_version_major = "python%s" % sys.version_info[0]
-@@ -549,7 +555,7 @@ def check_pypy_pre_import():
- assert module in sys.modules, "missing {!r} in sys.modules".format(module)
-
-
--@pytest.mark.skipif("platform.python_implementation() != 'PyPy'")
-+@pytest.mark.skipif("platform.python_implementation() == 'PyPy'")
- def test_pypy_pre_import(tmp_path):
- """For PyPy, some built-in modules should be pre-imported because
- some programs expect them to be in sys.modules on startup.
-@@ -622,7 +628,7 @@ def test_create_environment_from_venv(tmpdir):
- builder.setup_python(ctx)
- builder.setup_scripts(ctx)
- subprocess.check_call([ctx.env_exe, virtualenv.__file__, "--no-setuptools", "--no-pip", "--no-wheel", ve_venv_dir])
-- ve_exe = os.path.join(bin_dir, "python")
-+ ve_exe = os.path.join(bin_dir, os.getenv('EPYTHON'))
- out = subprocess.check_output([ve_exe, "-c", "import sys; print(sys.real_prefix)"], universal_newlines=True)
- # Test against real_prefix if present - we might be running the test from a virtualenv (e.g. tox).
- assert out.strip() == getattr(sys, "real_prefix", sys.prefix)
-@@ -639,7 +645,7 @@ def test_create_environment_from_venv_no_pip(tmpdir):
- builder.setup_python(ctx)
- builder.setup_scripts(ctx)
- subprocess.check_call([ctx.env_exe, virtualenv.__file__, "--no-pip", ve_venv_dir])
-- ve_exe = os.path.join(bin_dir, "python")
-+ ve_exe = os.path.join(bin_dir, os.getenv('EPYTHON'))
- out = subprocess.check_output([ve_exe, "-c", "import sys; print(sys.real_prefix)"], universal_newlines=True)
- # Test against real_prefix if present - we might be running the test from a virtualenv (e.g. tox).
- assert out.strip() == getattr(sys, "real_prefix", sys.prefix)
-@@ -657,10 +663,11 @@ def test_create_environment_with_old_pip(tmpdir):
- virtualenv.create_environment(venvdir, search_dirs=[support_dir], no_wheel=True)
-
-
-+@pytest.mark.skipif("platform.python_implementation() == 'PyPy'")
- def test_license_builtin(clean_python):
- _, bin_dir, _ = clean_python
- proc = subprocess.Popen(
-- (os.path.join(bin_dir, "python"), "-c", "license()"), stdin=subprocess.PIPE, stdout=subprocess.PIPE
-+ (os.path.join(bin_dir, os.getenv('EPYTHON')), "-c", "license()"), stdin=subprocess.PIPE, stdout=subprocess.PIPE
- )
- out_b, _ = proc.communicate(b"q\n")
- out = out_b.decode()
diff --git a/dev-python/virtualenv/virtualenv-16.7.10-r1.ebuild b/dev-python/virtualenv/virtualenv-16.7.10-r1.ebuild
deleted file mode 100644
index 1699ef11452b..000000000000
--- a/dev-python/virtualenv/virtualenv-16.7.10-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=manual
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/setuptools-19.6.2[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- test? (
- >=dev-python/pip-19.3.1-r1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pypiserver[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )"
-
-DOCS=( docs/index.rst docs/changes.rst )
-
-PATCHES=(
- "${FILESDIR}/virtualenv-16.7.7-tests.patch"
-
- # disable tests that need internet access
- "${FILESDIR}/virtualenv-16.7.7-tests-internet.patch"
-
- # test fixes for pypy
- "${FILESDIR}/virtualenv-16.7.8-tests-pypy.patch"
-)
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
-
-python_test() {
- cp "${S}"/LICENSE.txt "${BUILD_DIR}"/lib || \
- die "Could not copy LICENSE.txt with ${EPYTHON}"
-
- pytest -vv tests || die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
- elog "Please note that while virtualenv package no longer supports"
- elog "Python 2.7, you can still create py2.7 virtualenvs via:"
- elog " $ virtualenv -p /usr/bin/python2.7 ..."
-}
diff --git a/dev-python/virtualenv/virtualenv-20.4.4.ebuild b/dev-python/virtualenv/virtualenv-20.4.4.ebuild
deleted file mode 100644
index 5de5c2f6118a..000000000000
--- a/dev-python/virtualenv/virtualenv-20.4.4.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=manual
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
- >=dev-python/distlib-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/setuptools-41[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-0.12[${PYTHON_USEDEP}]
- ' python3_{6,7} pypy3)
- $(python_gen_cond_dep '
- >=dev-python/importlib_resources-1.0[${PYTHON_USEDEP}]
- ' python3_6 pypy3)"
-# coverage is used somehow magically in virtualenv, maybe it actually
-# tests something useful
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-freezegun-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- ' 'python3*')
- )"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
-distutils_enable_tests pytest
-
-src_configure() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local deselect=(
- tests/unit/activation/test_xonsh.py
- tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
- tests/unit/create/test_creator.py::test_cross_major
- )
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
- )
-
- distutils_install_for_testing
- epytest ${deselect[@]/#/--deselect }
-}
-
-pkg_postinst() {
- elog "Please note that while virtualenv package no longer supports"
- elog "Python 2.7, you can still create py2.7 virtualenvs via:"
- elog " $ virtualenv -p 2.7 ..."
-}