summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:46:05 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitf3d0bba11d88b2cf566d5e75a017ed60150dd3c5 (patch)
tree92afefaeacfc97b5587ff0532c9b3c7b96456c94 /dev-python/virtualenv
parentdev-python/regendoc: Add python3.5 support (diff)
downloadgentoo-f3d0bba11d88b2cf566d5e75a017ed60150dd3c5.tar.gz
gentoo-f3d0bba11d88b2cf566d5e75a017ed60150dd3c5.tar.bz2
gentoo-f3d0bba11d88b2cf566d5e75a017ed60150dd3c5.zip
dev-python/virtualenv: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild b/dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild
new file mode 100644
index 000000000000..77713a1002f8
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-13.1.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ http://www.virtualenv.org/
+ https://pypi.python.org/pypi/virtualenv
+ https://github.com/pypa/virtualenv/
+"
+SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/pip-7.1.2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( docs/index.rst docs/changes.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.2-no-versioned-script.patch
+ "${FILESDIR}"/${PN}-12.1.1-skip-broken-test.patch
+)
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -vvx || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}