summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 14:06:24 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 14:06:24 +0100
commit01be891e24b6d0e8ff872f45d1eb02870c62a097 (patch)
treeac0ddbe762360b1b8c88083f2b6a3d13ec1dffde /dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
parentdev-python/sphinxcontrib-napoleon: Remove old (diff)
downloadgentoo-01be891e24b6d0e8ff872f45d1eb02870c62a097.tar.gz
gentoo-01be891e24b6d0e8ff872f45d1eb02870c62a097.tar.bz2
gentoo-01be891e24b6d0e8ff872f45d1eb02870c62a097.zip
dev-python/virtualenvwrapper: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild')
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
deleted file mode 100644
index 31d2569cf569..000000000000
--- a/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
-HOMEPAGE="https://bitbucket.org/dhellmann/virtualenvwrapper
- https://pypi.org/project/virtualenvwrapper/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
-RESTRICT=test
-
-RDEPEND="
- dev-python/virtualenv[${PYTHON_USEDEP}]
- >=dev-python/stevedore-0.15-r1[${PYTHON_USEDEP}]
- dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]"
-
-# Keep just in case
-python_prepare_all() {
- sed -e 's:-o shwordsplit::' -i tests/run_tests || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
-}