summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-15 10:19:43 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-15 10:26:20 +0200
commit1b4368b4b2b0e25564086d759e0dcf15c769c7b9 (patch)
treeb1f9a00529dff3699f2b43f944ea2971a273e6cd /dev-python/wand
parentdev-python/spyder: fix indentation on 4.1.5 (diff)
downloadgentoo-1b4368b4b2b0e25564086d759e0dcf15c769c7b9.tar.gz
gentoo-1b4368b4b2b0e25564086d759e0dcf15c769c7b9.tar.bz2
gentoo-1b4368b4b2b0e25564086d759e0dcf15c769c7b9.zip
dev-python/wand: bump to 0.6.3
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/wand')
-rw-r--r--dev-python/wand/Manifest1
-rw-r--r--dev-python/wand/wand-0.6.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
index 3c1fc9abe518..5caace53b3e3 100644
--- a/dev-python/wand/Manifest
+++ b/dev-python/wand/Manifest
@@ -1 +1,2 @@
DIST Wand-0.6.2.tar.gz 10503865 BLAKE2B ad488a2d3d6b5801b20ca3caab884069cd5fb6913e04fb719885abdd49578f77cfc4b47a33235f4833463d75c01ad80e06c0687badb9c981a16c9c358c815032 SHA512 906490a0a75a4fc315b592fec12dea21cd40102c461381a79d5215c70ab6fb9c8a1e888fc478ea2ad006db6549dfdd2b7b1e01879cc2aba34dcc0cdd6ae2d128
+DIST Wand-0.6.3.tar.gz 10506834 BLAKE2B 65ba3d5719f7ad8d77a088d94344cc96f14ca45e95850494033a395cc8772d431653a16b2c3494268f351ee4187e5f5f0dbc22058266e9526cff2312e9a2c5b9 SHA512 9aef97434cc8cdef0880d1d1b2bbbdadba807543489d2c82725aa0b5287718f2a10f5508ca7d72a859e242e2b3e205e5f95649cb43be56d5eec8a83c272d0bac
diff --git a/dev-python/wand/wand-0.6.3.ebuild b/dev-python/wand/wand-0.6.3.ebuild
new file mode 100644
index 000000000000..094165125f7a
--- /dev/null
+++ b/dev-python/wand/wand-0.6.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+
+inherit distutils-r1
+
+MY_P="${PN^}-${PV}"
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="http://wand-py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-gfx/imagemagick"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ pytest -vv --skip-pdf || die "Tests fail with ${EPYTHON}"
+}