summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 05:44:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 05:49:58 +0200
commitb1c0baa3fda31e556ce8063f377db90334d4765a (patch)
treecd7e9e5169e616d83d007981744dbe39809ac75e /dev-python/wcmatch
parentdev-python/mkdocs-material: Bump to 9.5.23 (diff)
downloadgentoo-b1c0baa3fda31e556ce8063f377db90334d4765a.tar.gz
gentoo-b1c0baa3fda31e556ce8063f377db90334d4765a.tar.bz2
gentoo-b1c0baa3fda31e556ce8063f377db90334d4765a.zip
dev-python/wcmatch: Bump to 8.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wcmatch')
-rw-r--r--dev-python/wcmatch/Manifest1
-rw-r--r--dev-python/wcmatch/wcmatch-8.5.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index 9e1a9ccab3ab..69523c887f81 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1 +1,2 @@
DIST wcmatch-8.5.1.gh.tar.gz 117483 BLAKE2B db4d77651ab4fc6692c746d94dda68dc0fcdfe72a6e3b512b4f60a1bd5bf7015e21349d022c6ec17ea2bbc55ae87cf6c9a3690d9b6774f02a167b4b0ad65b691 SHA512 10ab7d76ad7c71efb2639e2d439593a45339f485f1f628770ae845c291c34d0e3fc8a9b75b6ce6d3c131c1f0a521f3aafcadc7d24ffad5284e9db06dc5838974
+DIST wcmatch-8.5.2.gh.tar.gz 117532 BLAKE2B f01ce989d1580da6575535a3c025aa50defe779ca723359dab379dda1c4c98d812343773d0130c56f8ebf74dae4472caa188b4b7b323f2df09686ebba297fa9a SHA512 1a79940bc54996f587dda6aacefee212adb4d527be68cc7b762e7e16c0796ebd833bdeb5abe6f48fa3d6d82f720ade054633ce28ee506b17c4d89cccffaa8e70
diff --git a/dev-python/wcmatch/wcmatch-8.5.2.ebuild b/dev-python/wcmatch/wcmatch-8.5.2.ebuild
new file mode 100644
index 000000000000..67f86264c16d
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.5.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-pymdownx-material-extras-2.0
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/
+"
+SRC_URI="
+ https://github.com/facelessuser/wcmatch/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/bracex-2.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}