summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-21 05:20:10 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-22 00:02:22 +0000
commit63d2f0be7a281f1a83a1915c42aa0ba7864c39a4 (patch)
tree07b86ef0fcc256532ca67f28e4422d80800828c7 /dev-python/wcsaxes
parentdev-perl/Crypt-SSLeay: Add version compatible with libressl-2.3 (no SSL2, no ... (diff)
downloadgentoo-63d2f0be7a281f1a83a1915c42aa0ba7864c39a4.tar.gz
gentoo-63d2f0be7a281f1a83a1915c42aa0ba7864c39a4.tar.bz2
gentoo-63d2f0be7a281f1a83a1915c42aa0ba7864c39a4.zip
dev-python/wcsaxes: fix documentation building
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/wcsaxes')
-rw-r--r--dev-python/wcsaxes/wcsaxes-0.6.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/dev-python/wcsaxes/wcsaxes-0.6.ebuild b/dev-python/wcsaxes/wcsaxes-0.6.ebuild
index 67bda681b879..0dc81c5fc21f 100644
--- a/dev-python/wcsaxes/wcsaxes-0.6.ebuild
+++ b/dev-python/wcsaxes/wcsaxes-0.6.ebuild
@@ -16,14 +16,19 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc test"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
dev-python/astropy[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
PATCHES=(
"${FILESDIR}/${PN}-0.6-disable_mpltest.patch"
"${FILESDIR}/${PN}-0.6-disable_numpy_warnings_test.patch"
@@ -35,7 +40,13 @@ python_prepare_all() {
}
python_compile_all() {
- use doc && esetup.py build_sphinx -w
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
}
python_test() {
@@ -43,6 +54,6 @@ python_test() {
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/ )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}