summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-31 19:34:00 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-31 19:34:00 -0700
commit5d1005ccb079ac41b9b017a203a289c40487188f (patch)
treeeb578cb0e5434e27dd05701a3923b0cc39d35152 /dev-python/wcwidth
parentmedia-gfx/termtosvg: version bump to 1.1.0 (diff)
downloadgentoo-5d1005ccb079ac41b9b017a203a289c40487188f.tar.gz
gentoo-5d1005ccb079ac41b9b017a203a289c40487188f.tar.bz2
gentoo-5d1005ccb079ac41b9b017a203a289c40487188f.zip
dev-python/wcwidth: version bump to 0.1.8
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest1
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.8.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index 6c606a7a7a1c..d136a7260f4b 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -1 +1,2 @@
DIST wcwidth-0.1.7.tar.gz 22884 BLAKE2B 6d51be31c6cf11a23de48bfecd00d8b95e15c80b83559f67689611ac0d8406c18e3a761dc57a868e8c991ee07e286aed66fe77d905483f63ee998ca431fd35f2 SHA512 5bc9625fbd10721a50a3ac7d7f91012cca8e4f83533f265cf56890498bc52a53b155c82e67d6bc5523a5593c8d7992a1dec2a0f590318170eddf987c56f9c368
+DIST wcwidth-0.1.8.tar.gz 19957 BLAKE2B dd4ba31bec5161a9509b0ef7e73901c3ff31b2ceedb3d05eeaf85f90c1157e21d00ee8cd0f715098bf65e5d699a40287ce08e235f2f1d22a73f6606f490a921d SHA512 b828450feb56b5c0e686f6922e777ab48d1336816a41ef4ef95f71c25a37ef492861634c16c788e1e4570d21bd4d45c990a18787860ba6043157c2781c78b65e
diff --git a/dev-python/wcwidth/wcwidth-0.1.8.ebuild b/dev-python/wcwidth/wcwidth-0.1.8.ebuild
new file mode 100644
index 000000000000..b4fe043cedd8
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.8.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest