summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-03-23 08:08:34 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2020-03-23 08:08:56 -0400
commit28d1a492801116f099a827ce77d02abcc2f108ae (patch)
tree593eebe3cb111b97305bfa46da1921e7aa92fb7d /dev-python/weasyprint
parentnet-misc/dropbox: 93.4.273 stable (diff)
downloadgentoo-28d1a492801116f099a827ce77d02abcc2f108ae.tar.gz
gentoo-28d1a492801116f099a827ce77d02abcc2f108ae.tar.bz2
gentoo-28d1a492801116f099a827ce77d02abcc2f108ae.zip
dev-python/weasyprint: Cleanup old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest2
-rw-r--r--dev-python/weasyprint/files/weasyprint-43-skip-failing-test.patch13
-rw-r--r--dev-python/weasyprint/files/weasyprint-43-skip-useless-deps.patch30
-rw-r--r--dev-python/weasyprint/weasyprint-0.41.ebuild50
-rw-r--r--dev-python/weasyprint/weasyprint-43.ebuild53
5 files changed, 0 insertions, 148 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 60185928ff33..5b354afe8b6d 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,3 +1 @@
-DIST WeasyPrint-0.41.tar.gz 393866 BLAKE2B 895624ee547a9ed91157db6a7a72890a56f270d2ea00a508c42899e42922e51867782b1dff3ab55f98df0a130b727a7db13aaf3553a90c4405b75b6813c95ab9 SHA512 44b2d9e0a186c5767cd01d6e66495241d088908467e0fa28cee114a9c480bfcb4ef393236e9304653603f3917c73c452c05a38286932e0a271946860120d9a1f
-DIST WeasyPrint-43.tar.gz 315365 BLAKE2B af643f6a6d09d09d89802dd3823e43e9f05873738b14e4f853a324850ffc12902cb791c3f187f6b550dded40669d376cf3d2e4d7d83e9747e87795a4d57e9014 SHA512 fc4c4decb298d4f9caf244433566c9b675b23db2508093d8c43c6e361119c5fe8298213075f550bebc72fe4156cfc516f04c8d7a2c6215fcd5add14360821f40
DIST WeasyPrint-51.tar.gz 308411 BLAKE2B f88f9e1abc09986d51d92d8a153c71242cadc8ce6b8ac99a08d86746677d40a86affe3c56dd3e3e6a0eb2fc915f77036271f049f6ccc644d508be51d01d97b7c SHA512 631038bece7ac0c15c6a668a7d06137e4bccc049eb80484a153ca9c4a996256de8647428b21ed1d0c1607af3893c747a1956a3d3f012b30105ba4f8613a96fcd
diff --git a/dev-python/weasyprint/files/weasyprint-43-skip-failing-test.patch b/dev-python/weasyprint/files/weasyprint-43-skip-failing-test.patch
deleted file mode 100644
index f49635fc8479..000000000000
--- a/dev-python/weasyprint/files/weasyprint-43-skip-failing-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/weasyprint/tests/test_layout/test_flex.py b/weasyprint/tests/test_layout/test_flex.py
-index 890df3e8..77c6bbf5 100644
---- a/weasyprint/tests/test_layout/test_flex.py
-+++ b/weasyprint/tests/test_layout/test_flex.py
-@@ -189,7 +189,7 @@ def test_flex_row_wrap_reverse():
-
-
- @assert_no_logs
--def test_flex_column_wrap_reverse():
-+def xtest_flex_column_wrap_reverse():
- page, = render_pages('''
- <article style="display: flex; flex-flow: column wrap-reverse;
- height: 50px">
diff --git a/dev-python/weasyprint/files/weasyprint-43-skip-useless-deps.patch b/dev-python/weasyprint/files/weasyprint-43-skip-useless-deps.patch
deleted file mode 100644
index 1229f0bed26d..000000000000
--- a/dev-python/weasyprint/files/weasyprint-43-skip-useless-deps.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -34,7 +34,6 @@
- [options]
- packages = find:
- zip_safe = false
--setup_requires = pytest-runner
- install_requires =
- cffi>=0.6
- html5lib>=0.999999999
-@@ -43,11 +42,6 @@
- cssselect2>=0.1
- CairoSVG>=1.0.20
- Pyphen>=0.8
--tests_require =
-- pytest-runner
-- pytest-cov
-- pytest-flake8
-- pytest-isort
-
- [options.entry_points]
- console-scripts = weasyprint = weasyprint.__main__:main
-@@ -72,7 +72,6 @@
- test = pytest
-
- [tool:pytest]
--addopts = --flake8 --isort
- norecursedirs = build dist .cache .eggs .git
-
- [coverage:run]
diff --git a/dev-python/weasyprint/weasyprint-0.41.ebuild b/dev-python/weasyprint/weasyprint-0.41.ebuild
deleted file mode 100644
index 18d60ad1e73f..000000000000
--- a/dev-python/weasyprint/weasyprint-0.41.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_6 )
-
-RESTRICT="test"
-
-inherit distutils-r1
-
-DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
-MY_PN="WeasyPrint"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="jpeg test tiff"
-
-# Note: specific subslot of pango since it inlines some of pango headers.
-RDEPEND="
- x11-libs/cairo
- x11-libs/gdk-pixbuf[jpeg?,tiff?]
- x11-libs/pango:0/0
- >=dev-python/cairocffi-0.5[${PYTHON_USEDEP}]
- >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
- >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
- >=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
- >=dev-python/pyphen-0.8[${PYTHON_USEDEP}]
- >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
- >=media-gfx/cairosvg-1.0.20[${PYTHON_USEDEP}]
- >=dev-python/pdfrw-0.4[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- media-fonts/ahem
- )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- py.test || die "testsuite failed under ${EPYTHON}"
-}
diff --git a/dev-python/weasyprint/weasyprint-43.ebuild b/dev-python/weasyprint/weasyprint-43.ebuild
deleted file mode 100644
index d50684ae43a1..000000000000
--- a/dev-python/weasyprint/weasyprint-43.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
-MY_PN="WeasyPrint"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="jpeg test tiff"
-RESTRICT="!test? ( test )"
-
-# Note: specific subslot of pango since it inlines some of pango headers.
-RDEPEND="
- >=x11-libs/cairo-1.15.4
- x11-libs/gdk-pixbuf[jpeg?,tiff?]
- x11-libs/pango:0/0
- >=dev-python/cairocffi-0.9[${PYTHON_USEDEP}]
- >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
- >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
- >=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
- >=dev-python/pyphen-0.8[${PYTHON_USEDEP}]
- >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
- >=media-gfx/cairosvg-1.0.20[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- media-fonts/ahem
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-43-skip-useless-deps.patch"
- "${FILESDIR}/${PN}-43-skip-failing-test.patch"
-)
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- pytest -vv || die "testsuite failed under ${EPYTHON}"
-}