summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 21:13:34 +0000
committerSam James <sam@gentoo.org>2021-02-27 21:39:18 +0000
commit7c0c3f3e597b1926f0c7378010b77b5b335f160a (patch)
treeb843e179d99f8e19b8aad28da9bf5dc9fda3de1a /dev-python/webassets
parentdev-python/yapsy: add Python 3.9 (diff)
downloadgentoo-7c0c3f3e597b1926f0c7378010b77b5b335f160a.tar.gz
gentoo-7c0c3f3e597b1926f0c7378010b77b5b335f160a.tar.bz2
gentoo-7c0c3f3e597b1926f0c7378010b77b5b335f160a.zip
dev-python/webassets: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/webassets')
-rw-r--r--dev-python/webassets/webassets-2.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/webassets/webassets-2.0.ebuild b/dev-python/webassets/webassets-2.0.ebuild
index 15cc85186663..c5a300af7a64 100644
--- a/dev-python/webassets/webassets-2.0.ebuild
+++ b/dev-python/webassets/webassets-2.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -24,7 +24,12 @@ BDEPEND="
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
!!dev-ruby/sass
- )"
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0-python39.patch"
+)
distutils_enable_tests pytest