summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 21:43:42 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:26 -0500
commit5210d0ec37894f2c8e2fee81771d712f9d011cf1 (patch)
treec2a62dec74888e7896c7882b970befe8e26ec7e4 /dev-python/webob
parentdev-libs/elfutils: revert "arm stable, bug #676794" (diff)
downloadgentoo-5210d0ec37894f2c8e2fee81771d712f9d011cf1.tar.gz
gentoo-5210d0ec37894f2c8e2fee81771d712f9d011cf1.tar.bz2
gentoo-5210d0ec37894f2c8e2fee81771d712f9d011cf1.zip
dev-python/webob: 1.8.5 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/Manifest1
-rw-r--r--dev-python/webob/webob-1.8.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/webob/Manifest b/dev-python/webob/Manifest
index 95128f245ea0..0398c1e7cdf5 100644
--- a/dev-python/webob/Manifest
+++ b/dev-python/webob/Manifest
@@ -1,3 +1,4 @@
DIST WebOb-1.7.3.tar.gz 216028 BLAKE2B 66af12ab34dc9a18555c6e480099a2c9b9f0ba8eb8f1e1066d501dea9ed2ff541c064bc40bfc74c284fef5f06281178d4d631b33f29c04d43da9c8e3bd138d0a SHA512 23a51f184754c525dc293b8b71855d40f52445c0df5434af7ec091219e0ea81be162623157b6ec67214cd151b25014bf86991246785816ebcb5a0d1eec9479a1
DIST WebOb-1.7.4.tar.gz 219331 BLAKE2B fe046905bf127dc8fedbf2b993e83b3614cd62ef614add939d54e241ecfc9a9ed77cfa5b961b436105c72cab36e885f94d604cd90909cc4ada9283c7a098a8ca SHA512 43685daf6dbba5daa99e4fabfb930495b8c2bc976e968d93af7681284cc127d7012f8423b2986dd7daa10cbf7b3803aec442c1ef88102e16cadf07efe6714d1a
DIST WebOb-1.8.2.tar.gz 271737 BLAKE2B c6eef650e9b03c83d7c618d0187ef7fbd3432d043ab27501cf8c4d6dc3889f3b542c54bf35963d8a313d62246183373c30706bcf5fd00495808e21d3dc9e0482 SHA512 691a6cfbbff376e7b1f71adcaac4dbe8cc26cb4ddc396e2ab946ddf15b34c05c638113f48ee396d4edaf6ef77498ca8539d1c63de9f58894afb0e4b88bbf04ae
+DIST WebOb-1.8.5.tar.gz 271955 BLAKE2B e1d22e91e8e04c88d6adcb4dcad93e1e0c37b5b3894eee7c2b5a92d2eea41719d3b42e05916bb355a3ac9a2f7357fe791ce6f776261bfc764eadf59d4be37bad SHA512 cc0b956a7c3b8ae58d6002baf5c6de4e442201280468f8fc8b5fbd2c7f7cb7a8f46447f97b98a32a9959c8d1aa7a2a8a7b9d624cb27ca79b2ad1ce94f891801b
diff --git a/dev-python/webob/webob-1.8.5.ebuild b/dev-python/webob/webob-1.8.5.ebuild
new file mode 100644
index 000000000000..baae1f1ad972
--- /dev/null
+++ b/dev-python/webob/webob-1.8.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+MY_PN=WebOb
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="https://webob.org/ https://pypi.org/project/WebOb/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ nosetests --verbose -w tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}