summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-11-09 16:54:17 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-11-09 17:19:51 +0300
commita7c145a1fc6bd06f781be9c5b218a318c2bb3707 (patch)
tree3fbe3a8febe86e55dbdb039bdb09d19e14f1ce95 /dev-python/webob
parentdev-python/waitress: eapi7 + py3_7 (diff)
downloadgentoo-a7c145a1fc6bd06f781be9c5b218a318c2bb3707.tar.gz
gentoo-a7c145a1fc6bd06f781be9c5b218a318c2bb3707.tar.bz2
gentoo-a7c145a1fc6bd06f781be9c5b218a318c2bb3707.zip
dev-python/webob: eapi7 + py3_7
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/webob-1.8.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/webob/webob-1.8.2-r1.ebuild b/dev-python/webob/webob-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..4c0774667c9a
--- /dev/null
+++ b/dev-python/webob/webob-1.8.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+MY_PN=WebOb
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="https://webob.org/ https://pypi.org/project/WebOb/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ nosetests --verbose -w tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}