summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-27 07:19:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-27 07:37:46 +0200
commit89af6c0e26ca68ebd17bf39f2458b6ce3cd9bdd3 (patch)
treef8f7227bbfd02238aa3c3decf3f8dce40aa005f4 /dev-python/websockets/websockets-9.1.ebuild
parentapp-admin/awscli: Bump to 1.20.7 (diff)
downloadgentoo-89af6c0e26ca68ebd17bf39f2458b6ce3cd9bdd3.tar.gz
gentoo-89af6c0e26ca68ebd17bf39f2458b6ce3cd9bdd3.tar.bz2
gentoo-89af6c0e26ca68ebd17bf39f2458b6ce3cd9bdd3.zip
dev-python/websockets: Skip tests that fail on slower hw
The ping tests tend to require execution with millisecond precision. This makes them fail on slower hardware. Closes: https://bugs.gentoo.org/804312 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets/websockets-9.1.ebuild')
-rw-r--r--dev-python/websockets/websockets-9.1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/websockets/websockets-9.1.ebuild b/dev-python/websockets/websockets-9.1.ebuild
index 6f59bacfa945..5e3b89269e27 100644
--- a/dev-python/websockets/websockets-9.1.ebuild
+++ b/dev-python/websockets/websockets-9.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
@@ -16,3 +16,12 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
distutils_enable_tests unittest
+
+src_prepare() {
+ # these fail due to timeouts on slower hardware
+ sed -e 's:test_keepalive_ping_with_no_ping_timeout:_&:' \
+ -e 's:test_keepalive_ping(:_&:' \
+ -i tests/legacy/test_protocol.py || die
+
+ distutils-r1_src_prepare
+}