summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-28 00:48:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-28 01:18:27 +0200
commitbf85c518b12558f590d691f8e2dca6f0cf1b0e58 (patch)
treed33a461f272248eb29f071142b195aade8072a63 /dev-python/websockets/websockets-9.1.ebuild
parentdev-perl/Email-Sender: Stabilize 1.300.34 x86, #792549 (diff)
downloadgentoo-bf85c518b12558f590d691f8e2dca6f0cf1b0e58.tar.gz
gentoo-bf85c518b12558f590d691f8e2dca6f0cf1b0e58.tar.bz2
gentoo-bf85c518b12558f590d691f8e2dca6f0cf1b0e58.zip
dev-python/websockets: Bump to 9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets/websockets-9.1.ebuild')
-rw-r--r--dev-python/websockets/websockets-9.1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/websockets/websockets-9.1.ebuild b/dev-python/websockets/websockets-9.1.ebuild
new file mode 100644
index 000000000000..ab6d5c255eef
--- /dev/null
+++ b/dev-python/websockets/websockets-9.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="https://websockets.readthedocs.io/"
+SRC_URI="https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}-src.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests unittest