summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-25 19:50:37 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-25 20:04:56 -0400
commitdc24dcfe979c3456c644e7c5b32a8f5e22428424 (patch)
tree66585c12c500dfb2ae6086d536c83eb17b9a0891 /dev-python/wheel/wheel-0.31.1.ebuild
parentdev-python/simplejson: version bump to 3.15.0 (diff)
downloadgentoo-dc24dcfe979c3456c644e7c5b32a8f5e22428424.tar.gz
gentoo-dc24dcfe979c3456c644e7c5b32a8f5e22428424.tar.bz2
gentoo-dc24dcfe979c3456c644e7c5b32a8f5e22428424.zip
dev-python/wheel: version bump to 0.31.1
Diffstat (limited to 'dev-python/wheel/wheel-0.31.1.ebuild')
-rw-r--r--dev-python/wheel/wheel-0.31.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/wheel/wheel-0.31.1.ebuild b/dev-python/wheel/wheel-0.31.1.ebuild
new file mode 100644
index 000000000000..f0aa2dd6026d
--- /dev/null
+++ b/dev-python/wheel/wheel-0.31.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.org/project/wheel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# dev-python/keyring
+# dev-python/keyrings_alt
+# dev-python/ed25519ll
+# dev-python/pytest[${PYTHON_USEDEP}]
+# )
+#"
+
+# Fails somehow
+RESTRICT=test
+
+python_test() {
+ sed \
+ -e 's:--cov=wheel::g' \
+ -i setup.cfg || die
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Signature support" \
+ dev-python/keyring \
+ dev-python/keyrings_alt \
+ dev-python/ed25519ll
+}