summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-19 18:38:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-19 18:42:02 +0200
commit15e2368f1e8ba0a78f802c7b645a8de3f25e516b (patch)
treecb3e1e9607988cf6968f9090b65ce928aa7ec4ba /dev-python/whichcraft
parentdev-python/jinja2-time: fix arrow compat, py3.7 & py3.8 (diff)
downloadgentoo-15e2368f1e8ba0a78f802c7b645a8de3f25e516b.tar.gz
gentoo-15e2368f1e8ba0a78f802c7b645a8de3f25e516b.tar.bz2
gentoo-15e2368f1e8ba0a78f802c7b645a8de3f25e516b.zip
dev-python/whichcraft: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/whichcraft')
-rw-r--r--dev-python/whichcraft/Manifest1
-rw-r--r--dev-python/whichcraft/whichcraft-0.6.1.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/whichcraft/Manifest b/dev-python/whichcraft/Manifest
index 61fd73b85c1f..0fbab8895219 100644
--- a/dev-python/whichcraft/Manifest
+++ b/dev-python/whichcraft/Manifest
@@ -1 +1,2 @@
DIST whichcraft-0.4.1.tar.gz 8095 BLAKE2B 666e4919698226e1f252f96323dd1fb56350e7b63424a0022fcf67f7afb83e3ec944b3689f1e58fbc29f1decbf8ce3d87aee9a9cb3a69621b2f65f235682068b SHA512 92633be99badd0ce06cf28b23366f89f2104ef2364ec8f637230fe46b378d1398a64f4d8b367358c833a2038159debc70b0498e94d2729918b95847defd59cae
+DIST whichcraft-0.6.1.tar.gz 8676 BLAKE2B c08dc453b1143da9c46f63d894526784724bff4861c1862a460f557c74e64bbde72c0127f9df0f6547a5c2183fe770e3ceaf417fed88ce70691ec28605f42e75 SHA512 3a8bf524437f3ee0b5b6ee16e4516ba1c75bee738edfef03316b1ef32a58d036734d75e626f113ad434acc29ccc0cce145668867148af7aa10de1fd5f739d5f6
diff --git a/dev-python/whichcraft/whichcraft-0.6.1.ebuild b/dev-python/whichcraft/whichcraft-0.6.1.ebuild
new file mode 100644
index 000000000000..a8eba54e66ad
--- /dev/null
+++ b/dev-python/whichcraft/whichcraft-0.6.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform cross-python shutil.which functionality"
+HOMEPAGE="https://github.com/pydanny/whichcraft"
+SRC_URI="https://github.com/pydanny/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+distutils_enable_tests pytest