summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-23 09:09:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-23 09:21:09 +0100
commit26f5cb1e5b2f3e084d438541a9afcd0d39594ce8 (patch)
treeeedf7666b123914fbc9e08ca927b6403d884866f /dev-python/wsproto
parentdev-python/python3-lxc: remove old 3.0.2 (diff)
downloadgentoo-26f5cb1e5b2f3e084d438541a9afcd0d39594ce8.tar.gz
gentoo-26f5cb1e5b2f3e084d438541a9afcd0d39594ce8.tar.bz2
gentoo-26f5cb1e5b2f3e084d438541a9afcd0d39594ce8.zip
dev-python/wsproto: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/Manifest1
-rw-r--r--dev-python/wsproto/wsproto-1.0.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/wsproto/Manifest b/dev-python/wsproto/Manifest
index 5b5967badff7..d8eaf468f9a3 100644
--- a/dev-python/wsproto/Manifest
+++ b/dev-python/wsproto/Manifest
@@ -1 +1,2 @@
DIST wsproto-0.15.0.tar.gz 51765 BLAKE2B 6eae2d2ceeb2d1e870c1ca70db22708fc2e5d10aac6b1d1a44ab00f4b31e18f21fd324c7e8c95e28769f4642601b775dc687eb28b419c5698ed68e617d054599 SHA512 c9666ec65374181da762f460f0c394a5bb599f8a0666989fb2d53e5e8822f5ebdd28eae3098e115d5bbacf6d6e1dd33a9cfeb808d569e1a01025eefaff18c531
+DIST wsproto-1.0.0.tar.gz 53423 BLAKE2B b4cc8c1ef0ccf324821b893b57fc86ab744c639dd07604618485004ef56ca105b5515e1f34a08ccc93de941b1a93eb76ef0d1946f11e05f80d40b98bfe7e4c56 SHA512 36f8c4eebf84bfe869f7124330898d22416b423f47396f2e3f72069e14f1763514e1df700c3e8ee81467cf973197e10143e088978d0688930fa98518af8773fb
diff --git a/dev-python/wsproto/wsproto-1.0.0.ebuild b/dev-python/wsproto/wsproto-1.0.0.ebuild
new file mode 100644
index 000000000000..642751d07b50
--- /dev/null
+++ b/dev-python/wsproto/wsproto-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/h11-0.9[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest