summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-05 10:22:38 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-05 11:32:20 +0100
commit0ebd34ea29b693908561d0b21a48e064eb5f841d (patch)
tree776ebb1cf474fbe7df34ad28ebf81fdb353a70dc /dev-python/wtf-peewee
parentdev-python/pytest-httpbin: Bump (diff)
downloadgentoo-0ebd34ea29b693908561d0b21a48e064eb5f841d.tar.gz
gentoo-0ebd34ea29b693908561d0b21a48e064eb5f841d.tar.bz2
gentoo-0ebd34ea29b693908561d0b21a48e064eb5f841d.zip
dev-python/wtf-peewee: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/wtf-peewee')
-rw-r--r--dev-python/wtf-peewee/Manifest1
-rw-r--r--dev-python/wtf-peewee/wtf-peewee-0.2.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/wtf-peewee/Manifest b/dev-python/wtf-peewee/Manifest
index 0e140a3ca737..d673446db421 100644
--- a/dev-python/wtf-peewee/Manifest
+++ b/dev-python/wtf-peewee/Manifest
@@ -1,2 +1,3 @@
DIST wtf-peewee-0.2.3.tar.gz 60654 SHA256 d64bab9c8b9b247f21534e87a94b988afd9655d7abaa14dc7d2af0bea3a3b9da SHA512 0a8e4a6586a4521d99c35b907935286c20b9106214a9826960073e710fc0a91c68402b9812d2b0119263786f8e48bdcacf999044ade9f3a27afa9bc7fd058926 WHIRLPOOL b44d3480d274f26ff84993c8941c473e6104bab8cd65bd8befb903dc9f2d6fad16299d6b4fc5f3b8af822dbc6aa9781dbe9ba43da6fb2f2dcf929578d3eac7ea
DIST wtf-peewee-0.2.4.tar.gz 60869 SHA256 e771daf99ec6ecab0771742f3bb104058cd5e0b72ad404c6d278b6eefc116349 SHA512 f63ecae4b39873124d11408a58732cc147a7b8a68b7f19be1f8ff67c4847b7daddd9f62c180a723af00176d2d13531fa30d076cf64ea618c260da522555ec7e7 WHIRLPOOL 0fcbc0c919e1df3af1f5d2787ebb8934c697e7dc6f65c9b264306d62a9b552e8969658c7cf6654f260b0e902b4aa3708aed694b36b4262cbf4e3e49aa2c9e43e
+DIST wtf-peewee-0.2.5.tar.gz 60905 SHA256 79bc345a1c543d78deaa0767f792c152abb34d9a90b98cbd65ac4cce8849d00b SHA512 10758f0617d28baee850d6a2f6041eaf16ac9accef3be51d8156bd0c387e6324708668c4c681f3a7fd7da309b6546e96e518d219905ac9148d51e59959bb9129 WHIRLPOOL 93c2518e6636536f9f57035468a76d3dd5477e8fdbed3bfbdbe652a91c6abbedd1835c7dd3031f49986786e408ac88d99710bcd40254cb3fe09e25a65e403c6b
diff --git a/dev-python/wtf-peewee/wtf-peewee-0.2.5.ebuild b/dev-python/wtf-peewee/wtf-peewee-0.2.5.ebuild
new file mode 100644
index 000000000000..53e3fca64dc3
--- /dev/null
+++ b/dev-python/wtf-peewee/wtf-peewee-0.2.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=dev-python/peewee-2.0.0[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( "${RDEPEND}" )"
+
+python_prepare_all() {
+ # https://github.com/coleifer/peewee/issues/361
+ sed -e s':test_null_form_saving:_&:' -i "${PN/\-/}"/tests.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}