summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-14 08:37:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-14 08:51:06 +0200
commitd77140e436c8f9b8bc4773c998f68605a4b01993 (patch)
treebdf25442aba6a9649c8692c6c6cb4ce756181e75 /dev-python/xdg/xdg-5.1.0.ebuild
parentdev-python/execnet: Bump to 1.9.0 (diff)
downloadgentoo-d77140e436c8f9b8bc4773c998f68605a4b01993.tar.gz
gentoo-d77140e436c8f9b8bc4773c998f68605a4b01993.tar.bz2
gentoo-d77140e436c8f9b8bc4773c998f68605a4b01993.zip
dev-python/xdg: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdg/xdg-5.1.0.ebuild')
-rw-r--r--dev-python/xdg/xdg-5.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/xdg/xdg-5.1.0.ebuild b/dev-python/xdg/xdg-5.1.0.ebuild
new file mode 100644
index 000000000000..6f45c65fcd8c
--- /dev/null
+++ b/dev-python/xdg/xdg-5.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of the XDG Base Directory Specification in Python"
+HOMEPAGE="https://github.com/srstevenson/xdg/ https://pypi.org/project/xdg/"
+SRC_URI="
+ https://github.com/srstevenson/xdg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# https://bugs.gentoo.org/773415
+RDEPEND="!dev-python/pyxdg"
+
+distutils_enable_tests pytest