summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-02 13:04:57 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-02 13:04:57 +0100
commit18d4c01423cea7ad761a45a460189148a07180c8 (patch)
treecc7aa9b1dd1b09cf9c0c90607917409d067f8a50 /dev-python/xlutils/xlutils-1.7.1.ebuild
parentdev-python/sphinxcontrib-httpdomain: Bump (diff)
downloadgentoo-18d4c01423cea7ad761a45a460189148a07180c8.tar.gz
gentoo-18d4c01423cea7ad761a45a460189148a07180c8.tar.bz2
gentoo-18d4c01423cea7ad761a45a460189148a07180c8.zip
dev-python/xlutils: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/xlutils/xlutils-1.7.1.ebuild')
-rw-r--r--dev-python/xlutils/xlutils-1.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/xlutils/xlutils-1.7.1.ebuild b/dev-python/xlutils/xlutils-1.7.1.ebuild
new file mode 100644
index 000000000000..59ffe9ea5f0e
--- /dev/null
+++ b/dev-python/xlutils/xlutils-1.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="provides a collection of utilities for working with Excel files"
+HOMEPAGE="https://pypi.python.org/pypi/xlutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=dev-python/xlwt-0.7.3[${PYTHON_USEDEP}]
+ >=dev-python/xlrd-0.7.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/errorhandler[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/testfixtures-1.6.1[${PYTHON_USEDEP}] )"
+
+DOCS="README.txt docs/*.txt"
+
+python_test() {
+ py.test xlutils/tests
+}