summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 14:09:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 14:09:22 +0200
commit89943e0c909375c82b90fadde38c43b864fa8348 (patch)
treebb796a9360cbdc6c3e39c846f9f537c39964bb3b /dev-python/xlwt/xlwt-1.2.0.ebuild
parentdev-python/xlwt: Stabilize 1.3.0 ALLARCHES (diff)
downloadgentoo-89943e0c909375c82b90fadde38c43b864fa8348.tar.gz
gentoo-89943e0c909375c82b90fadde38c43b864fa8348.tar.bz2
gentoo-89943e0c909375c82b90fadde38c43b864fa8348.zip
dev-python/xlwt: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xlwt/xlwt-1.2.0.ebuild')
-rw-r--r--dev-python/xlwt/xlwt-1.2.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/xlwt/xlwt-1.2.0.ebuild b/dev-python/xlwt/xlwt-1.2.0.ebuild
deleted file mode 100644
index c3abfc46f697..000000000000
--- a/dev-python/xlwt/xlwt-1.2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
-HOMEPAGE="https://pypi.org/project/xlwt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
- dev-python/pkginfo[${PYTHON_USEDEP}]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# Prevent d'loading in the doc build
-PATCHES=( "${FILESDIR}"/docbuild.patch )
-
-python_prepare_all() {
- # Don't install documentation and examples in site-packages directories.
- sed -e "/package_data/d" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests tests || die "tests failed under ${EPYTHON}}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}
- fi
- distutils-r1_python_install_all
-}