summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-03 08:11:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-03 10:52:21 +0200
commitfbddb437d73b886a48a966c2eea218e6ebd225ee (patch)
tree4e64028aba5bab838f8070d8535660b613642427 /dev-python/xmlschema
parentdev-python/reno: Bump to 3.4.0 (diff)
downloadgentoo-fbddb437d73b886a48a966c2eea218e6ebd225ee.tar.gz
gentoo-fbddb437d73b886a48a966c2eea218e6ebd225ee.tar.bz2
gentoo-fbddb437d73b886a48a966c2eea218e6ebd225ee.zip
dev-python/xmlschema: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.7.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index e5a68e087ad4..1348812c0cde 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-1.6.4.tar.gz 369270 BLAKE2B f3b98f0b8b4446dfa67da778c6b63585a894f4dcc9fd7ea98637ccd54b26e63aebc7f3fbc00e13ce43730b88da0f773a491917d5eae9301b5d22f6efe620473b SHA512 7e13d20a6add1cc5b6d0f732e672be3eeeb2f107fd2031cd5c22d1059d24b7d818c534817ea115d0c5f011727175bdcae71a0b8d55f1d6bd263a7e38286c26fc
+DIST xmlschema-1.7.0.tar.gz 370433 BLAKE2B 0270151705ca65d4b0f587e2ac75f7273a20242a0a315b4b954a6ccad6d46d7d093330a4c40d74a44c0c55af021da1c4ddde85f8431e0779d30e2164a599a335 SHA512 c4620f205cbdccef95a38eab6e6a5d6082681e3ff71708376f0ddeecd75a5c53f686fd740a41e98afd2ec5ec0f14be913b6c65bce80fab0143fa5fe1cc8a2ab6
diff --git a/dev-python/xmlschema/xmlschema-1.7.0.ebuild b/dev-python/xmlschema/xmlschema-1.7.0.ebuild
new file mode 100644
index 000000000000..be89448c38aa
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}