summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-02 18:42:24 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-02 18:42:24 -0800
commit15f0c6f901bad6cb376014b2085f69d064e756a5 (patch)
treec301e90f4e983cd3d4dce98286c748d713e82a1c /dev-python/xmltodict
parentdev-lang/jsonnet: Remove old (diff)
downloadgentoo-15f0c6f901bad6cb376014b2085f69d064e756a5.tar.gz
gentoo-15f0c6f901bad6cb376014b2085f69d064e756a5.tar.bz2
gentoo-15f0c6f901bad6cb376014b2085f69d064e756a5.zip
dev-python/xmltodict-0.12.0-r1: revbump, add py38, new distutils funcs
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/xmltodict')
-rw-r--r--dev-python/xmltodict/xmltodict-0.12.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/xmltodict/xmltodict-0.12.0-r1.ebuild b/dev-python/xmltodict/xmltodict-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..806632b8ff98
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.12.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.org/project/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests nose