summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-18 15:19:35 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-18 16:22:35 +0200
commita5c9047480b09883bc3c72579fcaa04a919da45c (patch)
tree8b0e4ce28c8a36202f5a44c394b27ea678988a7d /dev-python/xmltodict
parentdev-python/cached-property: update EAPI 7 -> 8, patch for py3.11 (diff)
downloadgentoo-a5c9047480b09883bc3c72579fcaa04a919da45c.tar.gz
gentoo-a5c9047480b09883bc3c72579fcaa04a919da45c.tar.bz2
gentoo-a5c9047480b09883bc3c72579fcaa04a919da45c.zip
dev-python/xmltodict: update EAPI 7 -> 8, nose --> pytest, py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/xmltodict')
-rw-r--r--dev-python/xmltodict/xmltodict-0.13.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/xmltodict/xmltodict-0.13.0-r1.ebuild b/dev-python/xmltodict/xmltodict-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..b8782693fc82
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.13.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/
+ https://pypi.org/project/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest