summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/xvfbwrapper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/xvfbwrapper')
-rw-r--r--dev-python/xvfbwrapper/Manifest2
-rw-r--r--dev-python/xvfbwrapper/metadata.xml9
-rw-r--r--dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild28
-rw-r--r--dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild28
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/xvfbwrapper/Manifest b/dev-python/xvfbwrapper/Manifest
new file mode 100644
index 000000000000..a154158ceaad
--- /dev/null
+++ b/dev-python/xvfbwrapper/Manifest
@@ -0,0 +1,2 @@
+DIST xvfbwrapper-0.2.2.tar.gz 3421 SHA256 58934508285c43aafac4179f26c34735b46c0bcb96b66198a4dbc68468e3cbb4 SHA512 ac71ec9a08189456c40e493f57802e872c03c0c5caf84493d77bf2e379853afe79099bcf5e5c7c0eb66ff1bf64e44bf37687a82b49864bc63a237f767752eed4 WHIRLPOOL cf3d39ff9eb68b3665c84c87cd7306134ca6d98734111855a777fe53a0528b5a212f3f082fe4d7734a460325875039511fa832e0ff9983c02c9dfc6b2bb54d90
+DIST xvfbwrapper-0.2.4.tar.gz 3215 SHA256 a7f52aefaf2e18c1aee302eb295ba9ca53ae6d3ba36df76794945a338a4b579c SHA512 26b14fd64c00ea33ad5f32dd69e59001f468ab294970ee281c81f1ae635cdea105b6057ba2e1012975fbb935ccb222585e70798e78c17f476d8b3e40f9e1346c WHIRLPOOL 791578eabe86fa9f3e6d44b9b03008fe8dbe2c9d853453afd29cfa28690d6f4cb44b948c5d991e4cdb7424a87fcce334bf7e403f2a6f781f6868f47af6a74268
diff --git a/dev-python/xvfbwrapper/metadata.xml b/dev-python/xvfbwrapper/metadata.xml
new file mode 100644
index 000000000000..ea7b0b684364
--- /dev/null
+++ b/dev-python/xvfbwrapper/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">xvfbwrapper</remote-id>
+ <remote-id type="github">cgoldberg/xvfbwrapper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild
new file mode 100644
index 000000000000..4f2a0c5d7169
--- /dev/null
+++ b/dev-python/xvfbwrapper/xvfbwrapper-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for running a display inside X virtual framebuffer"
+HOMEPAGE="https://github.com/cgoldberg/xvfbwrapper
+ http://pypi.python.org/pypi/xvfbwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="x11-base/xorg-server[xvfb]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pep8[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ unset DISPLAY
+ "${PYTHON}" test_xvfb.py || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild
new file mode 100644
index 000000000000..a6672d8167cb
--- /dev/null
+++ b/dev-python/xvfbwrapper/xvfbwrapper-0.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for running a display inside X virtual framebuffer"
+HOMEPAGE="https://github.com/cgoldberg/xvfbwrapper
+ http://pypi.python.org/pypi/xvfbwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="x11-base/xorg-server[xvfb]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pep8[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+# "${PYTHON}" test_xvfb.py || die "Tests failed with ${EPYTHON}"
+ "${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"
+}