summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 18:41:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 18:41:56 -0700
commit201e4144c98e3e8708d280e330e6e7179e7374e6 (patch)
tree4cd12d517152789118dfa2e0515ba83d8c291e3d /dev-python/yapf/yapf-0.30.0.ebuild
parentdev-python/yappi-1.2.5: Version bump (diff)
downloadgentoo-201e4144c98e3e8708d280e330e6e7179e7374e6.tar.gz
gentoo-201e4144c98e3e8708d280e330e6e7179e7374e6.tar.bz2
gentoo-201e4144c98e3e8708d280e330e6e7179e7374e6.zip
dev-python/yapf-0.30.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/yapf/yapf-0.30.0.ebuild')
-rw-r--r--dev-python/yapf/yapf-0.30.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/yapf/yapf-0.30.0.ebuild b/dev-python/yapf/yapf-0.30.0.ebuild
new file mode 100644
index 000000000000..5adb3c935492
--- /dev/null
+++ b/dev-python/yapf/yapf-0.30.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="A formatter for Python files"
+HOMEPAGE="https://github.com/google/yapf"
+SRC_URI="https://github.com/google/yapf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests setup.py