summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 01:28:10 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:26 -0500
commit1c6294c94161a983b14a00cbd478986f94713fc3 (patch)
tree70056f5811424d83233d6dbbe3f5149224d3028f /dev-python/yappi
parentdev-python/kombu: 4.4.0 bump (diff)
downloadgentoo-1c6294c94161a983b14a00cbd478986f94713fc3.tar.gz
gentoo-1c6294c94161a983b14a00cbd478986f94713fc3.tar.bz2
gentoo-1c6294c94161a983b14a00cbd478986f94713fc3.zip
dev-python/yappi: 1.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/yappi')
-rw-r--r--dev-python/yappi/Manifest1
-rw-r--r--dev-python/yappi/yappi-1.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index e0f44729c7d9..7f521d1616cc 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1 +1,2 @@
DIST yappi-0.98.tar.gz 37074 BLAKE2B 3a2c60f7c5987681f242230fc4fa0b87f924c0d1dbaedd3c240d30e6c440e2604e7add789cfd37052301a1f0ab99c81e2de30249fd6c83d5ba00624e131d266a SHA512 699e1845aac8e3c701c495913862597240b264c396b0b6ad0e9d6d533138caaeb883baeb036dc7b57bddf02ba411475401b2db77527d2ee63409d73b80f32098
+DIST yappi-1.0.tar.gz 38939 BLAKE2B b07b38bc07ffb6ba7aea3728ba6977680ca7f2dcc499778110aa31e733c512e5704cd580d01faf3344849df6772f110472a01328447228e9c45180beefc36f3e SHA512 d743c471ee3797b9f3b24c831fcb4ddf2cec7c13c56e567c0618eeada9a534ca0b114929da623a2c67142c61f3c38b024b25ba5e32883113148f4377f7574905
diff --git a/dev-python/yappi/yappi-1.0.ebuild b/dev-python/yappi/yappi-1.0.ebuild
new file mode 100644
index 000000000000..1c9e69e16698
--- /dev/null
+++ b/dev-python/yappi/yappi-1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{4,5,6,7}})
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="https://bitbucket.org/sumerc/yappi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}