summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/yapps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/yapps')
-rw-r--r--dev-python/yapps/Manifest1
-rw-r--r--dev-python/yapps/metadata.xml9
-rw-r--r--dev-python/yapps/yapps-2.2.0.ebuild24
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/yapps/Manifest b/dev-python/yapps/Manifest
new file mode 100644
index 000000000000..3ebfb046f2ed
--- /dev/null
+++ b/dev-python/yapps/Manifest
@@ -0,0 +1 @@
+DIST Yapps-2.2.0.tar.gz 13630 SHA256 d6e16a8e22ab559ca52eab58cb0015bb088d6889fa06db795222cdccae2354af SHA512 087f99071b2615f5382f453d9b3492675704aa7e7ff54b332d7c4e337e16fbd3ab3c1b3820a7941775c0b3ecf7e255a7773cb47ea20e8adb77dc3dc8d9a49faa WHIRLPOOL 1db693327d88445657fe0a4221928bdf0b81a6c7a238ad1f15579ea853975ce1da15b31c483a6782d43576b8f32024182d131061952d8d00493ca211b2a10eb2
diff --git a/dev-python/yapps/metadata.xml b/dev-python/yapps/metadata.xml
new file mode 100644
index 000000000000..6c460c309c0d
--- /dev/null
+++ b/dev-python/yapps/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Yapps</remote-id>
+ <remote-id type="github">smurfix/yapps</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/yapps/yapps-2.2.0.ebuild b/dev-python/yapps/yapps-2.2.0.ebuild
new file mode 100644
index 000000000000..d337dee924f3
--- /dev/null
+++ b/dev-python/yapps/yapps-2.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Yapps"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An easy to use parser generator"
+HOMEPAGE="https://github.com/smurfix/yapps"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"