summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 08:08:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 08:33:29 +0200
commit1642082635c3c4046efca6e0915920fd2d853be4 (patch)
tree0fa0780896e583f96823ae2399cf744a266eba76 /dev-python/zeroconf
parentdev-python/PySDL2: Bump to 0.9.8 (diff)
downloadgentoo-1642082635c3c4046efca6e0915920fd2d853be4.tar.gz
gentoo-1642082635c3c4046efca6e0915920fd2d853be4.tar.bz2
gentoo-1642082635c3c4046efca6e0915920fd2d853be4.zip
dev-python/zeroconf: Bump to 0.33.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.33.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 281b674bbf4e..ef759a3ac383 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,3 +1,4 @@
DIST python-zeroconf-0.32.1.gh.tar.gz 116507 BLAKE2B 03de415620745b75cd43be74b724faf909aad9628175f18cf4b2c04245d02adbca984eaa861e807729f36caa3feecab913f2e4aafcdd9aac1af02de6eeefbb3d SHA512 cefcd1abdc3ca2b5ed796aee09e6826c0d0f54343bdefbf45c425d6e033542dc061c84fb4438ba53774d87c6516801c6e2196c1e6cfdd9dbf9187f5d8d4b1b11
DIST python-zeroconf-0.33.2.gh.tar.gz 118266 BLAKE2B e239443c778d24895a830ac8d4f23be5eeac701b92ddf945efc955a731cbce62bea10243f57a0929ad21c4444d32c37b0a9e23b53e734362b9c6b9ce85e2eb59 SHA512 9631dc348baf028794934d826a1fd2e874cf9039e6fb1c93a1b9a8e2a95ae436ab2fc1a955e2d89656c37a56b71075b578857f6de041a7e61ff55c7a62a2a7a3
DIST python-zeroconf-0.33.3.gh.tar.gz 121202 BLAKE2B f457a65d26b58e4dac6c83b66be48e57ff0c34dd59dc3bfa008e2fd204f2f290088e6c784580114b91ddefce1cd2a3cea9310cfd4848c983c04749a1dbf3ebb8 SHA512 4e232fb9ad1e447333880d9737c3af3e9c652db2e0d7187d485cb6cdf8fe58076b78da4e1db3d2467b147c71343aeb18878f259bbfde6acd0faa3c4b9196222f
+DIST python-zeroconf-0.33.4.gh.tar.gz 121380 BLAKE2B a1a8ac266aaded65337aa9d5c26d8a52b6329500a1a18354148590fdb47988f200b0658a41e18b78694cd9f95f1322cce0ff289a795bf9459ab6d383d5ee13f9 SHA512 fa6dd453ea22beb113c53941ce750e214da3211b6fc14d8b0cb575b927cff14759c49fec4e9ada4a2fd4ebc0bb3b0b355a2454ca0e128a3213fc8be41f096af7
diff --git a/dev-python/zeroconf/zeroconf-0.33.4.ebuild b/dev-python/zeroconf/zeroconf-0.33.4.ebuild
new file mode 100644
index 000000000000..0e1b2943b16e
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.33.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect }
+}