summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-15 22:03:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-15 22:26:08 +0200
commit5c6ce06b9b3c7df3e22fa6cea217015f641afef2 (patch)
treeca0ea8342d833e150ff18f15053a5e63450949e3 /dev-python/zeroconf
parentdev-python/progressbar2: Bump to 3.53.3 (diff)
downloadgentoo-5c6ce06b9b3c7df3e22fa6cea217015f641afef2.tar.gz
gentoo-5c6ce06b9b3c7df3e22fa6cea217015f641afef2.tar.bz2
gentoo-5c6ce06b9b3c7df3e22fa6cea217015f641afef2.zip
dev-python/zeroconf: Bump to 0.36.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.36.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 2e3cf73d59ee..d8e01bbbaf27 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -2,3 +2,4 @@ DIST python-zeroconf-0.33.4.gh.tar.gz 121380 BLAKE2B a1a8ac266aaded65337aa9d5c26
DIST python-zeroconf-0.35.1.gh.tar.gz 127099 BLAKE2B dc09dadaeaac64d8517de407ddcfffc4152e366430c492d4ab562c56afa3264c33a26373f249bbddd969bb28dbc5c1b7513e59c0ebb728c12a77fb9d428e4f0a SHA512 27386cd425928821080c9c6fd2babdcfc001cc4583ef4c699169e3818f6bb8536f712cf7959e6003a6aaf40e85b5337a8a5abcfdf686455dee577cfa61270fb7
DIST python-zeroconf-0.36.1.gh.tar.gz 128104 BLAKE2B a5f2fdf35dd8c51e727ad1f4cd9ba442f2b99fd7ecc6ce0ce9cb0331997f445be90bba17571cec5ec0f59b64268241abacb5aee39134427098902b8d592494c6 SHA512 c568dd836a101a47ef74318154cd6c7fe2eb93c674450596f8e6ec4b7cfb66740126cc994b8f4d98458dd64a16c971ebab29b0877366396b8f5fabd03341107c
DIST python-zeroconf-0.36.2.gh.tar.gz 129052 BLAKE2B 4bdc4ac13064e162590af12da2d89cd566fbe749f1b11ebef210b2adbe7e33e75ff0e95d3ed11f7d045e016fff525c9a7b9124804d741160b0073016f4757d09 SHA512 2f2a7a87afa07907ed3aa3cd79d2f2e9b61e82193301f219f0505831349b003bca1ae2b6fc1dc71fcf6cb9cfb849413f9766ef88e3955fc569ad84fb9e5e5b60
+DIST python-zeroconf-0.36.3.gh.tar.gz 128887 BLAKE2B 57fa2359f5086eff9069334738db7515607309849b5d1e6bedfa16a7d24a12c068cf139d6885a85c418bf22c1033fa437670be6cce09b758af6d073f3cb37123 SHA512 a93799713ee7c4d507b350b4074bca23556275b1a1a14795a621f2cd9c10cf711fd80333e5685dae753207db265ab454a5bfe965cf44de77121bccd5ce8e1625
diff --git a/dev-python/zeroconf/zeroconf-0.36.3.ebuild b/dev-python/zeroconf/zeroconf-0.36.3.ebuild
new file mode 100644
index 000000000000..b416d399c1d2
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.36.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+)