summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-23 08:25:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-23 10:16:09 +0200
commit831a3607dad7ac0d104dbcb21490137dfdafb99e (patch)
treee32fe2f1bdb8f0da33f9eb1d2691454debf361c9 /dev-python/zeroconf
parentdev-python/platformdirs: Keyword 2.3.0 for ~m68k (diff)
downloadgentoo-831a3607dad7ac0d104dbcb21490137dfdafb99e.tar.gz
gentoo-831a3607dad7ac0d104dbcb21490137dfdafb99e.tar.bz2
gentoo-831a3607dad7ac0d104dbcb21490137dfdafb99e.zip
dev-python/zeroconf: Bump to 0.36.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.36.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index b2f61f6fb3df..aa1f64a3b27d 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -2,3 +2,4 @@ DIST python-zeroconf-0.35.1.gh.tar.gz 127099 BLAKE2B dc09dadaeaac64d8517de407ddc
DIST python-zeroconf-0.36.4.gh.tar.gz 128860 BLAKE2B ee6d02b583933404b6a1945235c1708e74211ae985a8c8e493098c59fe7003ef09223a87f9db87c78a22d0c1823748ea9f3aa1ca106a340d5df5a3ca6cfcb0bf SHA512 b1bfba10f374d006979ab0a626b9c3e9c0be25b07ad0f5242c463507b221cabfe11d18b02b29edc68f14b838b738b9a1265445fb8988e3243889454f17b3d7f3
DIST python-zeroconf-0.36.5.gh.tar.gz 129395 BLAKE2B 3e62da5f38bd0648ed300c2ecea712121cc3b8707871cf3de325cce0348b5972e538e70d74acfccb8540fa8253db992670902c13ac4b81928a47df4fa27d248e SHA512 ef51541da2c8d6703644750572d55093230ccf776b1a5bd67e0a6fa0f5f9762056b4cd7124e88efbee27ca768bbdf3e54fd051432d252f45376b7354bab4c50d
DIST python-zeroconf-0.36.6.gh.tar.gz 129469 BLAKE2B f52348d8fb5a2ed865bc946ad52ea0df474fd59ca5735411381366f08b2a5e1b673916256871128cc9f3a7fef1e72e2ea35fc113e5e41fe63f67659b3cc8f0ba SHA512 fe8d9026e9a19d267c7e734df51253bf69d5ca38b79b00b752886d59288073e8a4b9de40bbd2324064a574f40bec147c8b44d4f3395e480794600c440f2d7c9c
+DIST python-zeroconf-0.36.7.gh.tar.gz 129775 BLAKE2B 9b8ea59e2e62de4476c6b014b925b000b3c47cd9f965a23dd1c6a15b3a4f1ac7a4473eb6b9953d8893a445ffefcd1167c1e32b87b210ed3777fb046b3bd584f4 SHA512 c589c58c92d649c42f9a752d080c2b36a1fcc0c892ab6868cc79a3727087dd95f3e7b779ffd8b040d649453b8c70de4214d76d0f6c16c46a67628545c2472a54
diff --git a/dev-python/zeroconf/zeroconf-0.36.7.ebuild b/dev-python/zeroconf/zeroconf-0.36.7.ebuild
new file mode 100644
index 000000000000..b416d399c1d2
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.36.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+)