summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-29 23:37:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-29 23:49:05 +0200
commitc5654444a07e3289ec3d0f09683f7ab31444d9db (patch)
treeba35a45ac96c7d6235d1a24e0f535575138a147f /dev-python/zeroconf
parentnet-libs/libssh2: Bump to 1.10.0 (diff)
downloadgentoo-c5654444a07e3289ec3d0f09683f7ab31444d9db.tar.gz
gentoo-c5654444a07e3289ec3d0f09683f7ab31444d9db.tar.bz2
gentoo-c5654444a07e3289ec3d0f09683f7ab31444d9db.zip
dev-python/zeroconf: Bump to 0.36.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.36.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 3496c4474f06..ce20b6ff9b91 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -7,3 +7,4 @@ DIST python-zeroconf-0.34.3.gh.tar.gz 125454 BLAKE2B d80c25fa8bb79b6c5a3d491efc0
DIST python-zeroconf-0.35.0.gh.tar.gz 126620 BLAKE2B 1c2a7e78c32305be0c35fcef513e26c1834dee71b7714479c70c44a09378fb96a15f39fb4d9de4a8bde607cc4ef67798b5e6cb09e613f1a86cd9934123ab2ca9 SHA512 440871dd5fa861950187bf0c4593b2212d91477d4adbd41a43fd3adec820543628d684dfc042e38e4b69cd94e8b23d10298e660da32f8c221faf16e03135b925
DIST python-zeroconf-0.35.1.gh.tar.gz 127099 BLAKE2B dc09dadaeaac64d8517de407ddcfffc4152e366430c492d4ab562c56afa3264c33a26373f249bbddd969bb28dbc5c1b7513e59c0ebb728c12a77fb9d428e4f0a SHA512 27386cd425928821080c9c6fd2babdcfc001cc4583ef4c699169e3818f6bb8536f712cf7959e6003a6aaf40e85b5337a8a5abcfdf686455dee577cfa61270fb7
DIST python-zeroconf-0.36.0.gh.tar.gz 127299 BLAKE2B 66ee56eff026e427c3d0ce4353271a3232e0b3301cc364d9866f9beeedf9e41c9dcd97be82ce9fc0bdd79298d0fb2a89f51cb947f58cba8210be0f768032aaf6 SHA512 2f2bc44f5223a204ccf2106bf9fa3407640408c7199bddd68882b2024b07440e807a22e43b3aaa7eecc1f4fdefdf61f7a9b9a7655dd358355a43f03d67c13166
+DIST python-zeroconf-0.36.1.gh.tar.gz 128104 BLAKE2B a5f2fdf35dd8c51e727ad1f4cd9ba442f2b99fd7ecc6ce0ce9cb0331997f445be90bba17571cec5ec0f59b64268241abacb5aee39134427098902b8d592494c6 SHA512 c568dd836a101a47ef74318154cd6c7fe2eb93c674450596f8e6ec4b7cfb66740126cc994b8f4d98458dd64a16c971ebab29b0877366396b8f5fabd03341107c
diff --git a/dev-python/zeroconf/zeroconf-0.36.1.ebuild b/dev-python/zeroconf/zeroconf-0.36.1.ebuild
new file mode 100644
index 000000000000..0e1b2943b16e
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.36.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect }
+}