summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-10 07:29:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-10 07:57:07 +0200
commite7a2f8f396a56db03a08835182238c4be6ec63a2 (patch)
tree2eae355e3826c6ffa5f4ee69277763d0b03b1a6d /dev-python/zeroconf
parentdev-python/phonenumbers: Bump to 8.12.29 (diff)
downloadgentoo-e7a2f8f396a56db03a08835182238c4be6ec63a2.tar.gz
gentoo-e7a2f8f396a56db03a08835182238c4be6ec63a2.tar.bz2
gentoo-e7a2f8f396a56db03a08835182238c4be6ec63a2.zip
dev-python/zeroconf: Bump to 0.34.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.34.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index dc5d36d1f817..18676cee6bfa 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -3,3 +3,4 @@ DIST python-zeroconf-0.33.2.gh.tar.gz 118266 BLAKE2B e239443c778d24895a830ac8d4f
DIST python-zeroconf-0.33.3.gh.tar.gz 121202 BLAKE2B f457a65d26b58e4dac6c83b66be48e57ff0c34dd59dc3bfa008e2fd204f2f290088e6c784580114b91ddefce1cd2a3cea9310cfd4848c983c04749a1dbf3ebb8 SHA512 4e232fb9ad1e447333880d9737c3af3e9c652db2e0d7187d485cb6cdf8fe58076b78da4e1db3d2467b147c71343aeb18878f259bbfde6acd0faa3c4b9196222f
DIST python-zeroconf-0.33.4.gh.tar.gz 121380 BLAKE2B a1a8ac266aaded65337aa9d5c26d8a52b6329500a1a18354148590fdb47988f200b0658a41e18b78694cd9f95f1322cce0ff289a795bf9459ab6d383d5ee13f9 SHA512 fa6dd453ea22beb113c53941ce750e214da3211b6fc14d8b0cb575b927cff14759c49fec4e9ada4a2fd4ebc0bb3b0b355a2454ca0e128a3213fc8be41f096af7
DIST python-zeroconf-0.34.2.gh.tar.gz 125452 BLAKE2B 704ab1400a01eae93b1f706c2ccd4554b7ffbbcfcaebfc28bacf6e28354894185a7ed5cffddb3b96ff05dc3521d2507160a5f43c11a600c5b5043882d15c39e6 SHA512 958d01316ef307d08d68abe975f45d77e84cede8334f8ad023080b7d46f965f890b1c74de640807681d3aaa647e01902de01309e3520fba8ba18cb4b6af1f4ba
+DIST python-zeroconf-0.34.3.gh.tar.gz 125454 BLAKE2B d80c25fa8bb79b6c5a3d491efc0e891b08e808d9c2619d917a19d9d76ebdf13d32ddb684a3f68abd7ae6dce3597de30027557033a5ccacfe8dcc5bf624b45f25 SHA512 d9f1ab126dd68fdef2e2983a11efe7d3703bbacd7b74b9a82a781361b0282bf20d8c16bcf96beda7112958eab54e0b819f709d840a9e5f0f2da8c9003e9943fe
diff --git a/dev-python/zeroconf/zeroconf-0.34.3.ebuild b/dev-python/zeroconf/zeroconf-0.34.3.ebuild
new file mode 100644
index 000000000000..0e1b2943b16e
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.34.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect }
+}