summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-21 16:57:40 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-22 12:52:21 +0200
commit6b290794fe12f8998ed719abe5d3eb8836f70950 (patch)
treebb38bc17272e3b9ff2a8f4fb85e5b48f7fbbd80e /dev-python/zipp
parentdev-python/rst-linker: bump to python 3.10 (diff)
downloadgentoo-6b290794fe12f8998ed719abe5d3eb8836f70950.tar.gz
gentoo-6b290794fe12f8998ed719abe5d3eb8836f70950.tar.bz2
gentoo-6b290794fe12f8998ed719abe5d3eb8836f70950.zip
dev-python/zipp: bump to python 3.10
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/zipp-3.4.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/zipp/zipp-3.4.1.ebuild b/dev-python/zipp/zipp-3.4.1.ebuild
index e7eae1e79a92..49091cfd7e46 100644
--- a/dev-python/zipp/zipp-3.4.1.ebuild
+++ b/dev-python/zipp/zipp-3.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -36,5 +36,5 @@ python_prepare_all() {
python_test() {
# Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
# by ensuring only zipp from ${BUILD_DIR} is loaded
- pytest --ignore zipp.py -vv || die "Tests fail with ${EPYTHON}"
+ epytest --ignore zipp.py
}