summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-03 18:24:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-03 18:31:04 +0100
commit3128e7beecd38f1f191713c23ff933f5b64a5fdd (patch)
tree9f9a805619b963d0af2f4f0e445da573a7be2595 /dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
parentdev-python/zope-component: Remove namespace dep (diff)
downloadgentoo-3128e7beecd38f1f191713c23ff933f5b64a5fdd.tar.gz
gentoo-3128e7beecd38f1f191713c23ff933f5b64a5fdd.tar.bz2
gentoo-3128e7beecd38f1f191713c23ff933f5b64a5fdd.zip
dev-python/zope-deprecation: Remove namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild')
-rw-r--r--dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild b/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
deleted file mode 100644
index e0d43587ae93..000000000000
--- a/dev-python/zope-deprecation/zope-deprecation-4.4.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6..8} pypy3 )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope Deprecation Infrastructure"
-HOMEPAGE="https://github.com/zopefoundation/zope.deprecation"
-SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-distutils_enable_tests setup.py
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${ED}" -name '*.pth' -delete || die
-}