summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-19 18:19:07 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-19 18:29:11 +0200
commit5c75c6cd00d80c2700afa5326e072db20cca5696 (patch)
treeaae6d96775b78dbd1a5bc49c522c9c7340b0a7b0 /dev-python/zope-interface
parentdev-python/serpent: Add python3.5 support (diff)
downloadgentoo-5c75c6cd00d80c2700afa5326e072db20cca5696.tar.gz
gentoo-5c75c6cd00d80c2700afa5326e072db20cca5696.tar.bz2
gentoo-5c75c6cd00d80c2700afa5326e072db20cca5696.zip
dev-python/zope-interface: AVersion Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/zope-interface')
-rw-r--r--dev-python/zope-interface/Manifest1
-rw-r--r--dev-python/zope-interface/zope-interface-4.1.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/zope-interface/Manifest b/dev-python/zope-interface/Manifest
index 626a2c5e41fe..7fa6381ebcfa 100644
--- a/dev-python/zope-interface/Manifest
+++ b/dev-python/zope-interface/Manifest
@@ -1,2 +1,3 @@
DIST zope.interface-4.1.1.tar.gz 864139 SHA256 91cba7b7cd7cb82f6f4e023fe77f94dc3df4ae5287fd55def2148dc232d0c7da SHA512 77d8c978522e95063bb5a1feb5b20af341bcf447d393ceb1ea229f0db02408f0e8981226621c04988936730b265cdba0bab88aaacd7fdf1006281c297e8e1ca1 WHIRLPOOL 5ba337bcd3eb5c55cdb78ddbbd9843eb04c7b36c31819be4359849bc8cd453514fca38aa05fd78090cca80061b373e26d7a7cee1230fbf888c74f202b179c4b2
DIST zope.interface-4.1.2.tar.gz 919277 SHA256 441fefcac1fbac57c55239452557d3598571ab82395198b2565a29d45d1232f6 SHA512 b51f651ced7eb070db104e057a910b05a985999830551a6a7f83dcd2a565d637352b2dcf3b8517c682bed9365b31baf364f1863ff0e5b40df76668ea0b23a61e WHIRLPOOL 14729bacea73848508d67124d26eb966ec1ccdb14aeb9aa4ef0a0349d7241319f5f1b684fc9a6f4d6efdbed6ae120051c383aad67525dad2b4fca40fced2927d
+DIST zope.interface-4.1.3.tar.gz 141561 SHA256 2e221a9eec7ccc58889a278ea13dcfed5ef939d80b07819a9a8b3cb1c681484f SHA512 4579b7f3f5ae9cde83fcba24147f7480172015d3ec7480e4fac40d06f7846cf4fd1da966fc3e5c12c3f7058762052ef33d0535c685b120c1370d09d2274780e2 WHIRLPOOL 41b9eef46f581455346ed254aa73c2a2cb5dea0c27f506412fe90c66eaebeaa4fdb88d58e7ba4a0e9a7beb22df3f7d9039fcaac1961fe06fb9684f8f8509a243
diff --git a/dev-python/zope-interface/zope-interface-4.1.3.ebuild b/dev-python/zope-interface/zope-interface-4.1.3.ebuild
new file mode 100644
index 000000000000..ef2d80d19924
--- /dev/null
+++ b/dev-python/zope-interface/zope-interface-4.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Interfaces for Python"
+HOMEPAGE="https://pypi.python.org/pypi/zope.interface https://github.com/zopefoundation/zope.interface"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+# until all deps are in the tree (bug #442794)
+RESTRICT="test"
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}