summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-02-14 18:35:48 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-02-16 16:54:25 +0000
commit044a63e1562dd413a4b1d438e769057a6630b7e8 (patch)
tree69e3f2d088d3de5faa736bf36745890138cfcf9d /dev-python
parentapp-shells/zsh-completions: Sync live (diff)
downloadgentoo-044a63e1562dd413a4b1d438e769057a6630b7e8.tar.gz
gentoo-044a63e1562dd413a4b1d438e769057a6630b7e8.tar.bz2
gentoo-044a63e1562dd413a4b1d438e769057a6630b7e8.zip
dev-python/distro: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/distro/Manifest1
-rw-r--r--dev-python/distro/distro-1.0.2.ebuild21
-rw-r--r--dev-python/distro/metadata.xml20
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
new file mode 100644
index 000000000000..c7fac573015c
--- /dev/null
+++ b/dev-python/distro/Manifest
@@ -0,0 +1 @@
+DIST distro-1.0.2.tar.gz 27787 SHA256 77ec1f3695eed4dcda4e0e89d04dfcd91a20d3080d34f9294c5da47235382745 SHA512 df29ca40c1e7dd6e370396ceca684f5ce41fe50450faea104132d0e5dee05a91a525db715835c7efbca020e9c2e063bde9a6da07967eda6bfa8180856e175abb WHIRLPOOL 064c3ad4e0b82249a70dcb45d1b70ed3122209378fc83564060eeb815731b7454fa5952f794a4438a6f24b7cabfe6576c629598bc8f6f93ea2867a0f771856ee
diff --git a/dev-python/distro/distro-1.0.2.ebuild b/dev-python/distro/distro-1.0.2.ebuild
new file mode 100644
index 000000000000..96faecd11348
--- /dev/null
+++ b/dev-python/distro/distro-1.0.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="http://distro.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
diff --git a/dev-python/distro/metadata.xml b/dev-python/distro/metadata.xml
new file mode 100644
index 000000000000..ea74de39e0f3
--- /dev/null
+++ b/dev-python/distro/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ distro (for: Linux Distribution) provides information about the
+ Linux distribution it runs on, such as a reliable machine-readable
+ ID, or version information. It is a renewed alternative
+ implementation for Python's original platform.linux_distribution
+ function, but it also provides much more functionality which isn't
+ necessarily Python bound like a command-line interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">distro</remote-id>
+ <remote-id type="github">nir0s/distro</remote-id>
+ </upstream>
+</pkgmetadata>