summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-10-25 19:19:15 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-10-25 23:08:58 +0100
commit04c5b3983cc0f3c5f930b2156859040db026a241 (patch)
treed3835bdd95f8255ee54d4b4b4adc166baecf42f9 /dev-python
parentdev-python/botocore: add Whissi to maintainers (diff)
downloadgentoo-04c5b3983cc0f3c5f930b2156859040db026a241.tar.gz
gentoo-04c5b3983cc0f3c5f930b2156859040db026a241.tar.bz2
gentoo-04c5b3983cc0f3c5f930b2156859040db026a241.zip
dev-python/boto3: add new version 1.10.2
Cloned from 9999 ebuild verbatim. No new dependencies spotted. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.10.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 75e53cb21ad4..5a4d0c578867 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,2 +1,3 @@
+DIST boto3-1.10.2.tar.gz 272071 BLAKE2B 9c3b90ae751784946a84d0cf31ed0111526ed97b5be1fe5f256f725889f9819db632c6e6f217e3f01ebb0aa5594257a5bdaabd8dcc5f14ccb5bdd333b1c416c7 SHA512 37ea11f5ae9263aa5e97ce94f2834c987190ba2eac4a60bf9312bb643f1d204e48db7bef6ddc0d46ae124109ec6807589108b58f3024485de163fd8f83688b42
DIST boto3-1.9.122.tar.gz 258061 BLAKE2B 68903edd97e10693675e4c2fa77c2c54f2d3aab79307ee0a856f43aabe256f7782d027b0a23f433c593962c90f7364c26a87c27fe8770e67b5052e4ced73a9bc SHA512 31b8d8c2369b9076d825196d400c8a8b5579c38f87c7f41634eedbdaf6c2be01072018312e90e25d81b850c51f7c22a13fa565cd4e8b7672c238bad61e6a0810
DIST boto3-1.9.4.tar.gz 237313 BLAKE2B 20ab73dd02864b455a2bcc567b6303ef8b0503c4dd80efb442bf7ad8167329c938dcd41cbc61d4ab50fd02cbf8758c10aadb9b13d9c795330fe1faf9a1f7352b SHA512 7f0eb3b5537aed598d75a05474439819dee8c0030dd1eb685281e963ec465699ff9120394170f1ac7b53493de9b8702ec789863839eb3710ff3d60e2dfc1f1ac
diff --git a/dev-python/boto3/boto3-1.10.2.ebuild b/dev-python/boto3/boto3-1.10.2.ebuild
new file mode 100644
index 000000000000..bb665fd73e2b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.10.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-1.12.4[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/s3transfer[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}