summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-26 15:04:42 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-26 15:14:55 +0200
commit06e70e7f86d2bd70e1618a2e4e04512f548e9c8e (patch)
tree4aa75fd9a8af5b9184965f6ef3e0575533eb46fc /dev-python
parentdev-python/cython: Drop old (diff)
downloadgentoo-06e70e7f86d2bd70e1618a2e4e04512f548e9c8e.tar.gz
gentoo-06e70e7f86d2bd70e1618a2e4e04512f548e9c8e.tar.bz2
gentoo-06e70e7f86d2bd70e1618a2e4e04512f548e9c8e.zip
dev-python/cython: Bump to 0.29.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cython/Manifest1
-rw-r--r--dev-python/cython/cython-0.29.13.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index b875a7164551..4e857b26ce02 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -1,2 +1,3 @@
DIST Cython-0.29.12.tar.gz 2050537 BLAKE2B 86c5ffd07e97d549f2d98ae0aa66a03dc2f8e86b3fca304f3fba69f63c1e6d176c57d19f4877cdfd500ca2ebed2eaaebe1ed7cea0099fa23bc7a08c23f1b4f26 SHA512 502756331d8c3618a75a881fc1a20b7e871cd3412904070f3080d5bd0918440230fdae96f096c255fec6b32b81ffcf838f22953b8da23b8845527810f457be60
DIST Cython-0.29.4.tar.gz 2044382 BLAKE2B b36d27706a3270805f66190a4cf2735eaf20b1b932365b324a433c0e58e63e860ce1500333233c3539ae697886ac0adc361a2c158d5d064a3ea05843debc3f26 SHA512 8f115e36975aaf64eda4df8b0a85378d0c80b3292dbd162be826b939def03bdc9f3eb937676e2367003c2944b570d97f50d7880becfdb2fdc5144077b4a722dc
+DIST cython-0.29.13.gh.tar.gz 2072564 BLAKE2B 55a8c5c932262972cfa55ee2771e17ab5a57beab03d0dac5668f654a0bf68850ef62b7e59b322c527115af48b7243b9c919e739eaf440338a50b89c4645c0fbf SHA512 79efebfddabf31a046ae86a2c2170e0956098f4b1c7b8bbd338d30be7c96c31ee2d648332fc16ad9cf1e5d0ea4ca1a070b2d31ccbeae0c0f86a2f7700b92f656
diff --git a/dev-python/cython/cython-0.29.13.ebuild b/dev-python/cython/cython-0.29.13.ebuild
new file mode 100644
index 000000000000..fde90453842e
--- /dev/null
+++ b/dev-python/cython/cython-0.29.13.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs elisp-common
+
+DESCRIPTION="A Python to C compiler"
+HOMEPAGE="https://cython.org https://pypi.org/project/Cython/
+ https://github.com/cython/cython"
+SRC_URI="https://github.com/cython/cython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc emacs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ emacs? ( virtual/emacs )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
+
+SITEFILE=50cython-gentoo.el
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ fi
+
+ # Python gets confused when it is in sys.path before build.
+ local -x PYTHONPATH=
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use emacs && elisp-compile Tools/cython-mode.el
+
+ use doc && emake -C docs html
+}
+
+python_test() {
+ tc-export CC
+ # https://github.com/cython/cython/issues/1911
+ local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
+ "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES.rst README.rst ToDo.txt USAGE.txt )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+
+ if use emacs; then
+ elisp-install ${PN} Tools/cython-mode.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}