summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-18 11:56:37 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-18 11:56:37 +0200
commit0f4e47c3239dd251a9ff7281a095ad670ca428e9 (patch)
treebcb8135afb1301aad7436dd06be15e5ac6bbbfa9 /dev-python
parentdev-python/git-python: Bump (diff)
downloadgentoo-0f4e47c3239dd251a9ff7281a095ad670ca428e9.tar.gz
gentoo-0f4e47c3239dd251a9ff7281a095ad670ca428e9.tar.bz2
gentoo-0f4e47c3239dd251a9ff7281a095ad670ca428e9.zip
dev-python/humanfriendly: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/humanfriendly/Manifest1
-rw-r--r--dev-python/humanfriendly/humanfriendly-1.44.7.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index 61926296d9dc..7f179573c25f 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1,2 +1,3 @@
DIST humanfriendly-1.44.1.tar.gz 44281 SHA256 a9c545dc284c8e310465dba0b2300d898a9dc0d6eba5852f7578e03ff3ffc4ea SHA512 d5467e75c2e84c50dacaaab1c14b71a536eda5b91f4fc2d6ca69f1f1e50fe0ac215ac6cbf91cf7df08456f3058dcf84f0e38f611022c295e90c936e3b8a77cc9 WHIRLPOOL 869f86cd719fb9f3810767a37f43742ff21e9664229ccc4525873c84288fff8e9f08530796f54f2f1bea3b2df0601a424c5a253a42940c2d6a99cdbe19b20627
DIST humanfriendly-1.44.3.tar.gz 44682 SHA256 910a01f17d73536d53f0464c3d825e64efcb56fff80c58b383b78bfab5f934d0 SHA512 7ddba207e9946ea38ec7d4aaebe87c38ae7cec0f87d7576a8e99425f9678e7b90d830de2518ba898ba485d86e4b363022a9919dbf4fdf0b6cdd4bcf1629cd1b5 WHIRLPOOL 58683b1085e92d0d9c24a9b31c189f20a6d04f9a0eed8369ef180d0e0e66bcf878c251d61dcce905ad53223b480e1d244ff239d56b5a13d730c48952ec85007a
+DIST humanfriendly-1.44.7.tar.gz 45058 SHA256 fcee758612edc6fead9b8fd1d5a473eab2c3a84cf8766f3ce70862ccd35e8a64 SHA512 07ac1b6376dd144bb0fefaa5aa801cf05165d913ba9138bbaa0ab708fd262e76871a4821c7675ba10a2c212a3645c615a5abe01339c073730357dd85c0b94ffe WHIRLPOOL ab70278bed60136fa7aec3cbeb118458152e5a295c1cbc0cdecabc932e97eca4097ec37eae3dcbd12496a487818cb531c82a55fe9e75394d13cd8fc488b9871a
diff --git a/dev-python/humanfriendly/humanfriendly-1.44.7.ebuild b/dev-python/humanfriendly/humanfriendly-1.44.7.ebuild
new file mode 100644
index 000000000000..eef8e504f86c
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-1.44.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.python.org/pypi/humanfriendly https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ )
+ "
+python_test() {
+ esetup.py test
+}