summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-05 15:37:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-05 19:05:37 +0200
commit12ab06dc238aeaa51e4e10e50a8cc1badec8e15e (patch)
tree2a8cc59b8745f35d0c5a49aea570b755edca5369 /dev-python
parentdev-python/attrs: Bump to 20.3.0_p20210222 snapshot for py3.10 (diff)
downloadgentoo-12ab06dc238aeaa51e4e10e50a8cc1badec8e15e.tar.gz
gentoo-12ab06dc238aeaa51e4e10e50a8cc1badec8e15e.tar.bz2
gentoo-12ab06dc238aeaa51e4e10e50a8cc1badec8e15e.zip
dev-python/pytest: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest/pytest-6.2.4.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/dev-python/pytest/pytest-6.2.4.ebuild b/dev-python/pytest/pytest-6.2.4.ebuild
index 12ec533b3782..267da87475fd 100644
--- a/dev-python/pytest/pytest-6.2.4.ebuild
+++ b/dev-python/pytest/pytest-6.2.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Simple powerful testing with Python"
@@ -29,16 +29,18 @@ RDEPEND="
>=dev-python/py-1.8.2[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
"
-DEPEND="
+BDEPEND="
>=dev-python/setuptools_scm-3.4[${PYTHON_USEDEP}]
test? (
${RDEPEND}
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ ' python3_{7..9} pypy3)
)"
src_test() {
@@ -49,6 +51,8 @@ src_test() {
}
python_test() {
+ [[ ${EPYTHON} == python3.10 ]] && return
+
distutils_install_for_testing --via-root
"${EPYTHON}" -m pytest -vv --lsof -rfsxX -p no:pkgcore -p no:flaky ||