summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-28 06:56:47 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-28 06:56:47 +0100
commit13440a2da516a0c9794bd0bb1e8a7968254dc9a9 (patch)
tree42b97c8f52cba9d3e97b6b854f24a898cf80ef30 /dev-python
parentwww-client/qutebrowser: DISTUTILS_USE_SETUPTOOLS=rdepend in 1.10.1 (diff)
downloadgentoo-13440a2da516a0c9794bd0bb1e8a7968254dc9a9.tar.gz
gentoo-13440a2da516a0c9794bd0bb1e8a7968254dc9a9.tar.bz2
gentoo-13440a2da516a0c9794bd0bb1e8a7968254dc9a9.zip
dev-python/parso: Disable failing error tests
Disable error tests that started failing with Python 3.8.2 as they depend on exact exception messages. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/parso/parso-0.6.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/parso/parso-0.6.1.ebuild b/dev-python/parso/parso-0.6.1.ebuild
index d33ced31acc5..d9dff2d95d49 100644
--- a/dev-python/parso/parso-0.6.1.ebuild
+++ b/dev-python/parso/parso-0.6.1.ebuild
@@ -19,3 +19,11 @@ RESTRICT="!test? ( test )"
distutils_enable_sphinx docs
distutils_enable_tests pytest
+
+src_prepare() {
+ # tests rely on specific exception messages and fail occasionally
+ # upstream suggested skipping them
+ rm test/test_python_errors.py || die
+
+ distutils-r1_src_prepare
+}